"Server uses different class table"

When I try to play on most of the servers, I can’t as it says “Server uses different class table”. What does that mean? How can I prevent that from happening so It lets me play on the server?
I don’t know if the problem started since I etable"ntered a specific Gmod server, because after going to that server non of the other servers let me join because of "Server uses different class .

The class tables were updated with the most recent release. Either you or the servers you are trying need to update. Try a different server and also make sure you can play “single player” just on your own (lan game).

I think the other servers need updates as they are kind of crappy ones such as normal sandbox servers.

Try finding one with a few people in it. I know for a fact that the server my buddies and I are running is update and before that I ran into a few class table issues. C’mon people… the update came out long ago… update your servers!

Yeah, any time I’ve experienced that error it’s because the server I’m trying to join hasn’t updated. Simply quitting Garry’s mod and re-launching it should force an update if you think it’s your Gmod client that is out of date. If not, try restarting steam a couple of times.

I just started getting this error on my own server, even after i updated both client and server. I think i might have messed up the server update though, because i forgot to shut it down before i updated. The update window told me it was unable to delete some files, but the rest of the update worked fine. I tried updating again without the server running, and im still getting this error.

Let the servers update. Update 59 was just released.

I can’t join my own server either and I just tried to update it. :frowning:

Hello I Get Same Problem… And i Updated My Server With : hldsupdatetool -command update -game garrysmod -dir C:\srcds

Please Help

Same here. This needs to be fixed…

Same here… I updated it… but I still cannot join it? and i know I am up to date. Here is what it says.

Starting the Steam Update…
Don’t close this window. If you close this window the update will still be executed on the server

Stopping the game server…
Game server has been stopped.
Checking bootstrapper version …
Updating Installation
Logging in as ‘phantomyoda’
Checking/Installing ‘Team Fortress 2 Dedicated Server’ version 51

Checking/Installing ‘Base Source Shared Materials’ version 8

Checking/Installing ‘Base Source Shared Models’ version 4

Checking/Installing ‘Base Source Shared Sounds’ version 4

Checking/Installing ‘GarrysMod Content’ version 62

HLDS installation up to date
Starting the game server…
Game server has been started.
The Steam update has completed. You may close this window.

Says it went fine… but I still cannot join it… or anyone else… we all get the error. It has been like this for over a week now.

Contact your server provider?

Nice. 666 posts X_X. I might just reinstall a new gmod server… Our RPG server has no issue… and its with the same hosting company. Thanks for the help.

Here’s what I did, I deleted all of my orangebox files and folder in my srcds folder, and then I just reinstalled it. Worked fine.

I finally got my server to work today and it’s shown on the internet list, blah, blah. But when my friend tried to join it has this problem. I updated my server with hldsupdate and it still doesn’t work.

How do you “update” a server? I own one and I can’t join because it has different class tables. I have the most up-to-date. So I need help to update the server.

Didn’t want to take up more space on the forums so I recycled this. It’s kind of old I know, but saves space right?
:doh:

gmod just updated for me and now i get this error…

This error means your version of Gmod is not the same as the server. Either you or the server has to update. Seeing as you just downloaded an update, the server has to update.

What we are saying is that, despite updating the servers, we still cannot join. I will try “BoingBoing’s” idea and report back.

OK I resolved the issue by deleting everything inside the server’s garrysmod directory except the following: addons, cfg, data, gamemodes, lua and maps.

I was using Garry’s Mod and I was trying everything possible, and I fixed it!
[HOW TO FIX]
First, go to right click on Gmod in the Steam Library and click Properties
Then go to “Beta” and reselect “Dev” to “Opt out of all betas”
Finally, let Gmod update and then launch the Game!

Hope this helps!


(User was banned for this post ("really dumb bump." - postal))