Server wont start after updating

Thanks for all the help, I have now solved me issue, although I don’t know how to lock the thread, if a moderator see’s this, could you lock this thread please!

Hello guys,
I currently run a 24/7 TTT server, it has worked perfectly for the last couple of months, although I went to update it today and now it wont start, it does not make a log so I found this

dump file: [URL=“http://www.mediafire.com/?iuhqm3iob16j9f9”]
I have no idea what to do with the dump file or why my server keeps crashing.

When I try to launch my server it just closes and opens again constantly, here is a screenshot of it;

Server starter code:


@echo off
cls
echo Protecting srcds from crashes…
echo If you want to close srcds and this script, close the srcds window and type Y depending on your language followed by Enter.
title srcds.com Watchdog
:srcds
echo (%time%) srcds started.
start /wait orangebox\srcds.exe -console -nocrashdialog -nohltv -game garrysmod -port 27015 +clientport 27005 +hostport 27015 +tv_port 27020 +ip “192.168.1.66” -maxplayers 20 +map ttt_67thway_v4 +sv_loadingurl "havocservers.com/index.php?threads/179/"
echo (%time%) WARNING: srcds closed or crashed, restarting.
goto srcds

You haven’t provided much information as to what is actually happening. Does it just stop responding? Post a screen of it crashing.

Updated post

I have tried re downloading CS:S and Garry’s Mod for my TTT server, and no luck, still gives me the same error

It’s not the content that’s the problem. It never begins to load any of your gamemodes. It’s the core gmod files located in orangebox/bin that’s the problem

How can I fix them? Shall I try deleting all of them and re-install/download the server files again?

To make sure you have the latest version of the files you can delete all files in the folder and restart you server. It should re-download then.

I’ve been getting this often since gm13 (and in the beta). However, that been said the current release it hasn’t happend to me on at all.

Basically you have to keep verifying the files, each time it will find 5-10 files from orangebox/bin that are stale and need redownloading. After each verify try your server again, if still fails try again. I’ve had to do it 20-30 times at one point of the beta :/.

Thanks for all your help 12voltsdc, ms333 and Pantho, my server is now working fine now!

I just updated 9 servers without it happening once though, seems to be fixed for me :slight_smile: