Server works but...

Alright guys I need some help. When I join my game, everything works but the default tools aren’t there. My keys, unarrest stick, arrest stick say “Print name” and are blank. Something isn’t getting included in here. Any suggestions?

Are you sure you installed DarkRP correctly?

Yep, put the dark rp gamemode in the gamemode folder on my file browser in the Admin Control panel. I am assuming that I forgot to include some content somewhere. What content might this be? I got an error in console saying

Error creating ‘keys’ (Make sure the file is AddCSLuaFile’d and there aren’t any errors!)
Error creating ‘gmod_camera’ (Make sure the file is AddCSLuaFile’d and there aren’t any errors!)
Error creating ‘pocket’ (Make sure the file is AddCSLuaFile’d and there aren’t any errors!)
Error creating ‘weapon_keypadchecker’ (Make sure the file is AddCSLuaFile’d and there aren’t any errors!)
O

[editline]23rd February 2014[/editline]

Yep, put the dark rp gamemode in the gamemode folder on my file browser in the Admin Control panel. I am assuming that I forgot to include some content somewhere. What content might this be? I got an error in console saying

Error creating ‘keys’ (Make sure the file is AddCSLuaFile’d and there aren’t any errors!)
Error creating ‘gmod_camera’ (Make sure the file is AddCSLuaFile’d and there aren’t any errors!)
Error creating ‘pocket’ (Make sure the file is AddCSLuaFile’d and there aren’t any errors!)
Error creating ‘weapon_keypadchecker’ (Make sure the file is AddCSLuaFile’d and there aren’t any errors!)
O

Type in sv_allow cslua. If that doesn’t work, try reinstalling DarkRP.

Why would he do that?

Because… wait im dumb.