Servers not up atm?

G’day,

After I read the Steam update thing, if I click “Play Game” no servers are there, the join buttons are available, but if I click on them, it will load but it won’t go all the way up to the “Meshing” stage.
Is there something to do with Steam, do I have to download the game on Steam or something?

Just not too sure, sorry if the answer is right in front of me :S

[editline]13th October 2013[/editline]

Additional Info

The Flags aren’t loading (the pictures) and if I click “Join” it either says “No server selected” - if it does manage to load, it doesn’t get the the meshing stage / connecting to server, and just sits there.

So far I have tried this on Google Chrome, Nightly, and Internet Explorer.

Any help would be great :slight_smile:

Same here i cant find the servers.

they are working on it, it’ll pop back up soon…

Cheers guys :slight_smile:

Remember that the game is still in alpha and the servers will restart/crash sometimes.
Always wait 5 minutes after the server goes down to see if it goes up or not, if it is not back in 5 minutes please post it on the forums.

Ok, I think I may have fixed it.

I used a program called CCleaner, and so I ran it and I went Play Game and the server list loaded, it looks different to what it was, so I’m guessing it works :smiley:

They fixed them cammo.

If you are having issues seeing the server list, clear your browser cache.

how do you clear your browser cache

Which browser are you using?