Servers /w different port issue

Hi.

I am hosting multiple garrys mod servers, using the ports in the range 27000-27500.

I am experiencing a problem, where player can’t connect to any of the ports except for the 27015 one (the default one). Players cannot find the servers with the other ports (27025, 27035, 27016, etc.)in the server list and cannot retrieve the server info when attempting to join it via Steam or Garry’s Mod console.

Players are able to join once they have joined the 27015 server or if they try to join through the forums. It’s really strange as once they join the error no longer occurs.

Before anyone claims that it could be something to do with the server, even when I create a fresh vanilla server the issue occurs.

Thank you in advance. :smiley:

Are your ports forwarded?

Yup, I’ve port forwarded.

Are there any firewalls that could be restricting acess to the other ports?

Nope, no firewalls.

I am co-creator with Trippy of the servers.

We have a dedicated server, with a dedicated ip, no port forwarding is neccessary. We’re running a clean iptables, where all packages have ACCESS.

We too are suspecting a firewall, but outside of our reach.
Our host is soyoustart/ovh. Maybe others have tried this before?

We have tried logging all new inbound connections, and the people unable to join, does not appear in the log. We might log it wrong tho?

This is the iptables config (After we added logging, before i was just ACCEPT on everything):

Solved:

Had nothing to do with GMOD. Our host were actually blocking the packets, due to their DDoS protection configuration.

We changed the configuration, and it seems to work now.

The rules were

  • Do not allow new connections on iregular ports (like 27015). (explaining why you could join through the join link on our webpage)
  • And then there was a specific rule by default to allow srcds on port 27015, explaining why no other ports where working.

Now, next time someone has this issue, a google search will lead them here! :slight_smile: