Set up everything, server still not working.

I’ve forwarded my ports, I’ve run the HLDS update tool, I’ve tried everything I’ve seen and can think of. Can anyone please help me figure out what I’m doing wrong?

I’m using my laptop as a server, if that changes anything.

What is it doing exactly? Does it open up fine, but nobody can connect or what?

[editline]10:16PM[/editline]

btw, don’t host a server over a wireless connection

From what you posted in the GMF you gave you LAN IP, give them your internet one.

Check my link might help a little http://www.facepunch.com/showthread.php?t=920869

No that won’t help at all

so whats wrong with your server it coming up with an error or something my tut should be simple enough to run off any computer done right at least.

] connect 192.168.1.13;27015
Network: IP 192.168.1.102, mode MP, dedicated No, ports 27015 SV / 27005 CL
Unknown command “27015”
Connecting to 192.168.1.13…
Retrying 192.168.1.13…
Retrying 192.168.1.13…
Retrying 192.168.1.13…
Connection failed after 4 retries.

^What my friend gets when he tries to connect. How can I give him my internet IP?

[editline]11:27PM[/editline]

It’s only for 2 people anyway, so I’m gonna try out that Hamachi thing.

Your internet IP: http://ipcake.com/

fist off right there it tells you your port is wrong its :27015 not ;27015

Yes and thats his internal/local ip, he should be using his external and be using :

yes my tut goes over this how to make so you don’t get no problems your server aint set to the ip right and next you’ll probly have allocated problems

Do this were you dedicated server is find the srcds.exe file create a txt file and put. then saveas and put in Startup.BAT and run it. and go to no-ip.com and find out your real ip so your friends can join


@echo off 
cls 
echo Protecting srcds from crashes... 
echo If you want to close srcds and this script, close the srcds window and type Y depending on your language followed by Enter. 
title srcds.com Watchdog 
:srcds 
echo (%time%) srcds started. 
start /wait c:\srcds\orangebox\srcds.exe -console -update -game garrysmod +hostname "Name of server" +maxplayers 18 +sv_Defaultgamemode SandBox +Map GM_flatgrass +clientport 27006 +tv_port 27021 +hostport 27016 +Ip 192.168.1.13
echo (%time%) WARNING: srcds closed or crashed, restarting. 
goto srcds

You don’t need to specify ip, ever.

Face it your tutorial sucks stop preaching it.

ya my tut suck when it runs my server Fine and i followed other tuts that are just the same so suck it and preach that.

And if your running off a router and don’t have you ip specified it will give you error couldn’t allocate server

Haha guess what, mine is patched in to a router, and i haven’t specified the IP, and it works fine. Now what could that be because of :downs:

I think I was giving him the wrong IP. He’s going to test the other IP for me in a few minutes.

Thanks for all your help, guys.

[editline]09:15PM[/editline]

Okay, I gave him the other IP, and when he adds it to his favorites so he can connect with the password, the “Connect” button is grayed out and it won’t let him click the server. Any ideas?

[editline]09:17PM[/editline]

Nvm, he connected