Setting default gamemode?

So how do I set a default gamemode? Cause my gamemode is at Sandbox atm but I want it to be DarkRP.

Also my " Changegamemode (Gamemode) " console command got replaced as " changelevel " command? D:

When you type changegamemode ingame, it would be like this.


 changegamemode <rp_downtown_v2> <DarkRP> 

Something like that.
And put this in your server.cfg



sv_defaultgamemode "DarkRP"
sv_gamemode "DarkRP"


If you want this for servers (srcds), add this to the command line: +sv_defaultgamemode “DarkRP”

If you want it client-side, do as Keyword said.

Okay thanks that worked, now I have darkrp 2.4.1 do you know where I can get darkrp 2.4.2? and when I use SVN it makes my darkrp into DarkRP 2.3.5

DarkRP 2.3.5 huh… That’s odd. When I download the SVN it gives me 2.4.2

To get DarkRP 2.4.2, you have to get TortoiseSVN.
Make a folder called DarkRP, right click and there should be a option “SVN Checkout”.
Choosing that option will open a dialog box.
Paste this in the first textbox:
darkrp.googlecode.com/svn/trunk/
Then click “Ok”, and then it should download.
Wait for it to download and click “Ok” when it is finished.
You now have DarkRP 2.4.2, enjoy.
For more help, add me on steam: zyoxxxx