Setting default server map without command line

I tried putting “map ttt_minecraft_b5” in autoexec.cfg. This does not work, but “gamemode terrortown” does work in autoexec.cfg. I’ve even tried “changelevel ttt_minecraft_b5” but still not working.
For some reason the host I have does not have a startup command line setting, and they haven’t replied to my tickets yet. Please tell me how i can do this with the server files.
Thanks!

Just put map ttt_minecraft_b5 in your server.cfg and make sure nothing else in any .cfg or .lua file is setting the map. There’s also the possibility that the command line that you don’t have access to is setting the map already.

map ttt_minecraft_b5
I put that in the server.cfg and now there’s a “bad field” error in the console.

Does the map command work for any other map, like gm_construct?

It works for all maps

Interesting, I never knew you could actually set the map from the config files… I thought you had to tell SRCDS prior to startup what map to load, not after during server startup.