Setting NPC Behavior

Hi. I downloaded a really bad clone trooper NPC pack once, and I tried to make them act like stormtroopers but prevent them from attacking the player, but they will kill you anyway! I set the setting “ENT.PlayerFriendly” to 1, and they still attack! Is there anything else I need to do?

Well you can aways use the “notarget” cheat (or turn off target player in NPC menu),but that wont work if you want other NPC’s to target you!
Actualy I think there was a tool or addon that was able to change good to bad and bad to good,but dunno!