Setting up Gmod server

I used SteamCMD to set it up and when I connect, it lets me. But after I’m on none of my friends can join…
It says it’s not dedicated either which I thought it was and the worst part is this
WARNING: Port 27015 was unavailable - bound to port 27016 instead
WARNING: Port 27005 was unavailable - bound to port 27006 instead
WARNING: Port 27020 was unavailable - bound to port 27021 instead

I have no idea why because I DID forward my ports. Pleas help me this is urgent ://

This doesn’t have to do with port forwarding. It can’t bind to those ports because another application is already listening to them, probably Gmod or another Source game. Start the server before you start the game and it should work.

I do everytime. I start the server up before and then start the game and it doesn’t work. Can you add me on steam and help me dude! My steam name is istealpussy

Are you running something else that could use those ports? Another instance of the server? Another Source server?

I am not running any other servers at all :frowning:
I have no idea what’s wrong with it I just gave everything a restart and it still doesn’t work.

As long as it is actualy binding to a port people should still be able to connect.

Just port-forward ports 27000-27025 and you should be fine.

Don’t forward 27015? Do 2700 - 27025?

Do a range of ports because the server will rebind to different ports since you’re playing on the same computer you’re hosting with.

Ok I did that. Besides changing it on the website my IP uses is there any other place I should change my ports? Or add it somewhere in the control panel or no?

No, they will automatically rebind. You can force the port by putting -port portnumber in your server launch parameters.

The specified port(s) are being used by other configurations. Please check your configurations of Remote Management, Port forwarding, Port Triggering, UPnP Port Mapping table, RIP, and Internet connection type

[editline]9th March 2014[/editline]

I checked all the configs, and no ports are being used :frowning: Wtf!

[editline]9th March 2014[/editline]

Ok I fixed the ports, That is now working I Didnt put the extra 0 in 27000 lol. Put Let me see if it works now :smiley:

[editline]9th March 2014[/editline]

It still doesn’t work :frowning:

You really shouldn’t be using the same network you play on to host. Honestly, if you can’t figure out how to set ports, just use Hamachi.

I don’t like hamachi :confused: I don’t wanna have to pay $60 a month to host when I can do it for free

Hamachi is free…

I normally would never recommend it, but if you really can’t find a solution and you’re determined on hosting on the same network, then it might be for the better.

I ment like NFO servers which is somewhere around $60 a month :frowning: