Setting up server, can't connec to my own

I set up a simple theater server using the theater game mode and map that is on the workshop. Extracted the files form the addons files, put them all in their places, port forwarded, etc. Got everything to work and my friends over the internet can connect to the server just fine, play videos just fine and do everything. However, I have no idea how to connect to my own server, I want to join the server from the same computer that the server is running on. It shows up in the LAN tab and I try joining it, connection failed after 4 tries. The computer I am using to host the servers internal IP is 192.168.1.17 so I tried doing connect 192.168.1.17, connect 192.168.1.17:27015, connect 192.168.1.1, connect localhost, etc. nothing I have tried has worked, all fail to connect. I have tried googling for a solution, but all the issues are “I CAN connect to my own server but OTHERS over the internet CAN’T” and it’s almost always a port forward issue. I don’t think that’s my issue.

Would appreciate any help or ideas. Thank you.

go to whatsmyip.com and you will see your ip. Use that ip instead of the 192.168.1.17, but still use the port. For example, 108.38.239.101 is my ip, so my friend will type


connect 108.38.239.150:27015

in the console and press enter, and he will connect to me.
Your ports may need to be open, but you can google that.

No that doesn’t work. Tried it before, tried it again just now. I’m trying to connect to my server that I’m hosting LOCALLY not trying to connect to it over the internet, although others can connect to it over the internet just fine, I want to be able to join my own server on the same computer I’m hosting it on.

Sounds like a firewall issue blocking a local connection. But what’s strange is that you can’t even connect to it over a public connection. Do you have another computer with GMod to see if it’s not working on just that computer?

No, I don’t have another computer to test it with. I made a rule in my firewall to allow both TCP and UDP connections inbound and outbound from port 27000-27015 and disabled avast, still no luck.

Did you try adding all the above ip’s to your steam server favorites list, and seeing which one of them shows your server after a couple refreshes?

I had a similar problem where I couldn’t connect to my srcds server with the external ip, But when I connected with the local ip (192.168.0.100) it worked just fine.

He said he tried connecting locally. I don’t remember if this works on source servers, since it’s been a while since I’ve hosted a server on the same computer, but you can try connecting through localhost or 127.0.0.1

Welp. Tried all that, didn’t work.

Pardon the reapeat, but are you POSITIVE you port forwarded correctly? I’ve been running servers for a while and that screams port forwarding problem to me.

Feel free to post your config or screenies of the routerlogin.

If you can, DMZ host your local IP. That way there will be no problems.

https://s3.amazonaws.com/img.ctrlv.in/img/51a1c7e66f77f.png

Keep in mind I tried a bunch more ports then that that I found on the wiki, however I deleted them because they weren’t working either.

Tried that. Didn’t work. I guess that means it’s not a port forwarding issue since DMZ should open all ports?

I also tried disabling UPnP. No luck.

Just out of curiosity, have you gone to Garry’s Mod main menu, hit ‘Find Multiplier Game’ and the clicked ‘Local Network’?

Yes. I have been primarily trying to connect through the LAN tab. My local 192.168.1.17 address.