SetupArrayProps_R: array prop 'null' is at index 0 Startup Fail

Fresh installed 3 times, and re-checked them all with hldsupdatetool and -verify_all in use, yet nothing has worked, every time GMod starts, this error appears. All the other servers (installed at the same time, batch file), work fine, it’s only GMod which doesn’t. Valve issue? Garry issue?

Exact error:

[lua]
SetupArrayProps_R: array prop ‘null’ is at index 0
[/lua]

I have the exact same problem.
It was working before I updated the TF2 and DODS content for it.
It seems many other people are having the same problem.

Bump?
This thread is bleeding its way down the list…

Great, looks like it’s probably either a distribution error from Valve, in which case there’s like no hope of a fix for years.

If it works without tf2/dods, install it “raw” and copy materials/models accross for it should work.

Or, it could be Garry, in which case there might be hope for a fix, sometime…

Someone has to have a fix for this, as it’s not a 1 time problem it seems right now…

I am Jack’s unsettled stomach.

Anyone got a fix that doesn’t include reinstalling everything just to see it break again? I also just updated TF2 then DoD and now i’m also getting this.

I’m having the same problem. Happened right after I updated the tf2 content on my server.
I haven’t found a solution anywhere else, but it seems like this isn’t the first time this has been a problem.

We are the ghosts of the servers, trying to reanimate our windows command prompts. But in reality, out servers are dead forever.
Unless we actually DO find a fix…

Edit: Hoster isn’t a real word.

Yeah! Server Hosters in Server Hosting! Who would of thunk it.

Fix: don’t install tf/dods the normal way, install elsewhere and copy accross materials/etc, although that’s now giving me animation issues with playermodels, but at least the server runs.

Basically, other tf2-engine source games are “different” somehow.

What?

Nothing…
Anyway, how can I do all this crap without having to reinstall the server?
Last time I reinstalled, it took me 2 days to install all the game content (even crap from .gcf files).

Edit: random thought…
what if I removed the relists folder? Oh, no. That would also screw up Portal and Episode Two.
Can anyone tell me exactly what the files in the relists folder for tf2 and DODs are called so I can delete them?

Thanks.

Yeah, looking for a fix that doesn’t include me having to reinstall, like Plastique said the gcf’s are the main shits that you don’t wan’t to be constantly messing with, not to mention the time it takes and we have no idea that installing tf2/dod will just break it again.

I updated the tf2 and dod:s content on my box in a seperate folder, copied it into each of my servers and then re-extracted the gcf’s and mine works 100%… No problems as of yet…

I really wish somebody could actually fix this. Not just work around it, but actually fix it.

Does anyone know which files to delete?
I moved the DODS and TF folders to my desktop so that it wouldn’t try to mount them, but it failed. Again, I think the bug is in the realists folder.
Averice. You said that you updated the tf2 and dods content in a different folder. Can you tell me the names of the files that weren’t in the dods or tf2 folders, but in the folder that was updated? That way, I can just look for those and delete them.
I don’t think the actual content folders are causing the problem.

I have the same problem. The server runs fine with only GMod, but errors out when I add the other content.

It’s also not consistent. I am getting the error on my home GMod server but not my hosted one, and both were installed in the same manner.

This is starting to get annoying. I tried reinstalling twice and it still doesn’t fix it. Doesn’t anybody have any idea about why this is happening?

I think I found a way to fix it, it worked for me…

  1. Delete the “<SRDS DIRECTORY>\orange box\bin” folder
  2. Delete the “<SRDS DIRECTORY>\orange box\garrysmod\bin” folder
  3. Run hldsupdatetool to update garry’s mod data: “hldsupdatetool -command update -game garrysmod -dir <SRDS DIRECTORY>”

That worked for me, thanks! I’ve been having a lot of trouble with this and have no idea where it stems from.