SetVelocity not work... HELP!

i made my entity and use “SetVelocity” function…
but my entity did not work anything

init.lua

AddCSLuaFile( “cl_init.lua” )
AddCSLuaFile( “shared.lua” )
include(‘shared.lua’)

function ENT:Initialize()

self:SetModel( "models/ItemBox/itembox.mdl" )
self:SetPos( self:GetPos() + Vector(0,0,50) )
self:PhysicsInit( 6 )     
self:SetMoveType( 6 )
self:SetSolid( 6 ) 
--self:DropToFloor()
self:PhysWake(  ) 

end

function ENT:Think()
self:SetVelocity(Vector(0,0,50000000000000))

Msg( "Timer...

" )–1sec
self:NextThink( CurTime() + 1 )
return true

end

function ENT:OnTakeDamage(dmg)
self:Remove()
end

cl_init.lua

include(‘shared.lua’)

include(‘shared.lua’)

function ENT:Draw()
self:DrawModel()
end

share.lua

include(‘shared.lua’)

include(‘shared.lua’)

function ENT:Draw()
self:DrawModel()
end

has my code error?

Please wrap your code with code tags.
Your problem is that the velocity you are trying to set isn’t recognized as an actual number because it is too big, try lowering it.
The source engine also has a maximum velocity of 3500 units/second.

self:GetPhysicsObject():AddVelocity(Vector(0,0,50000000000))

You have to set the velocity on the physics object if it uses MOVETYPE_VPHYSICS.

You might want to lower it though since that’ll crash the game or delete the entity being so high.

oh i did’t know but
first try is not 500~~
i try to 500 power(?) but do not anything, so that power set to 500~

Thanks!

[editline]21st December 2013[/editline]

OH you are my angel!

very thanks!

[editline]21st December 2013[/editline]

Sorry, i didn’t know what called “code tags” but now is not!
Thank!