Several GMod bugs and Workshop bugs


While testing my map RP_Littletown I encountered several problems/bugs:

When downloading my map from Workshop every soundscape and soundscript included in the .bsp file aren’t loaded when starting the map. Everything does exist, manual playing via console (playsoundscape <name>) does work, but in the console there is no message telling me it was loaded with the map (as it should be!).
Using the same map not downloaded from Workshop, everything works fine.
(Careful, to test it, first use the Non-Workshop version, or you have to remove every link to the Workshop version in several files in your garrysmod directory!).

So: Soundscripts and Soundscapes aren’t working when downloading a map from Workshop.

When testing RP_Littletown in multiplayer (using the non-Workship version with working soundscapes!) on a listen server, every player except the host had Error: Bad Soundscape in develope mode. Playing them manually via playsoundscape command worked.

So: Soundscapes seem not to be loaded for every player except the host on listen servers.

Since GMod 13 Beta, every prop_door_rotating rotates 360° if I press Use while it is opening.

func_areaportal_window’s seem to be buggy. When fading in or out, the “replacement brush” isn’t shown. It just gets visible as soon as the fading is complete. This is not normal. Tested on RP_Littletown, too.

Every of these bugs far aren’t appearing in Half-Life 2: Episode 2 and weren’t appearing in Garry’s Mod 12.


Custom particle effect support seems to be included, as far as the Valve Developer Wiki says. However, since it doesn’t work in most Orange Box games, Garry’s Mod still doesn’t support them in GMod 13.

I know this thread is old but Soundscapes still don’t work for maps that are downloaded from the workshop. :frowning:

Prop_door_rotating always rotated 360° when you use it while it’s opening. Happens in HL2 as well I think.