Severe stuttering, unless I reset the affinity.

Ever since I moved back from Linux into Windows, all source engine games have issues with my processor. I’m running a dual core CPU, so naturally I would want to use the multicore rendering option. However, after switching back into Windows, it makes my game stutter massively. I can fix this in all the games by changing the options, but garrysmod still has the issue. There is no option for multicore rendering for me, and the mat_queue options don’t help. The only thing that does is to reset the affinity in task manager.

Does anyone know why this is happening? I would like to have multicore rendering working at least, I get really poor FPS without it.