shadow problems.

so i putted the value of light_environment entity pitch yaw roll to 0 31 0 and pitch to -31 and then shadow_control with same pitch yaw roll as light_environment but shadows are not showing up. any help?

map leak

how i can fix it?

post your compile log

if it’s a leak, go to map > load pointfile and follow the red line to where there is a gap touching the void.

Hello again i am back now… there is the vmf file so tell me what’s wrong :confused:

Download

We aren’t just going to fix your problem for you, how are you going to learn, post the compile log like others have said and load the pointfile.

maybe you got it wrong… just tell me the correct settings to get shadows?

Post the compile log so we can look at it. Without the compile log it is like ringing up the garage and asking why your car won’t start…then refusing to tell them anything more.

There are no settings involved if there’s a possiblity of you having a leak, post the damn compile log.

compile log:



** Executing...
** Command: "d:\steam\steamapps
ikkelipaa\sourcesdk\bin\orangebox\bin\vbsp.exe"
** Parameters: -game "d:\steam\steamapps
ikkelipaa\garrysmod\garrysmod" "D:\Steam\steamapps
ikkelipaa\sourcesdk_content\gmod\mapsrc\gm_kyokkigoodie.vmf"

Valve Software - vbsp.exe (Oct 31 2012)
4 threads
materialPath: d:\steam\steamapps
ikkelipaa\garrysmod\garrysmod\materials
Loading D:\Steam\steamapps
ikkelipaa\sourcesdk_content\gmod\mapsrc\gm_kyokkigoodie.vmf
Could not locate 'GameData' key in d:\steam\steamapps
ikkelipaa\garrysmod\garrysmod\gameinfo.txt
fixing up env_cubemap materials on brush sides...
ProcessBlock_Thread: 0...1...2...3...4...5...6...7...8...9...10 (0)
ProcessBlock_Thread: 0...1...2...3...4...5...6...7...8...9...10 (0)
Processing areas...done (0)
Building Faces...done (0)
FixTjuncs...
PruneNodes...
WriteBSP...
done (0)
writing D:\Steam\steamapps
ikkelipaa\sourcesdk_content\gmod\mapsrc\gm_kyokkigoodie.prt...Building visibility clusters...
done (0)
Creating default LDR cubemaps for env_cubemap using skybox materials:
   skybox/sky_day01_01*.vmt
 ! Run buildcubemaps in the engine to get the correct cube maps.
Creating default HDR cubemaps for env_cubemap using skybox materials:
   skybox/sky_day01_01*.vmt
 ! Run buildcubemaps in the engine to get the correct cube maps.
Finding displacement neighbors...
Finding lightmap sample positions...
Displacement Alpha : 0...1...2...3...4...5...6...7...8...9...10
Building Physics collision data...
done (0) (2353 bytes)
Placing detail props : 0...1...2...3...4...5...6...7...8...9...10
Compacting texture/material tables...
Reduced 9 texinfos to 4
Reduced 3 texdatas to 3 (57 bytes to 57)
Writing D:\Steam\steamapps
ikkelipaa\sourcesdk_content\gmod\mapsrc\gm_kyokkigoodie.bsp
0 seconds elapsed

** Executing...
** Command: Copy File
** Parameters: "D:\Steam\steamapps
ikkelipaa\sourcesdk_content\gmod\mapsrc\gm_kyokkigoodie.bsp" "d:\steam\steamapps
ikkelipaa\garrysmod\garrysmod\maps\gm_kyokkigoodie.bsp"


No VVIS or VRAD in the compile log?

vrad = lighting. I think we have found your problem.

In compile settings, put everything to normal then compile.

thank you for your answers :slight_smile: i’ll try at next time

thank you very much ironphoenix. you made it work. thread lock request…