Shadows through a solid floor?

I didnt include a screenshot but the floor is a brush that entirely closes off the floor above it. I just dont know why the shadows are going through. Thanks

You can reduce the props’ shadow cast distance in their properties.

The shadow functions for dynamic/physics props has always been very broken. Just select all prop_physics/prop_dynamic and disable shadows and it won’t happen.

There is a way to prevent this.

  1. Post your question in the question megathread.
  2. Put a shadow_control in your map.
  3. Under “Pitch Yaw Roll” set it to point straight down (I think its “90 0 0”)
  4. No more shadows on walls, shadows still appear on floors.

I had this same problem, I think that step is where I went wrong on my map.

Does that walls brush extend to the floor above?

Both areas are in the same PVS, which is why they cast to the floor below.