Simple model with bones in Blender?

I can create static props fine, collisions and all, but I cannot find good info about bones in Blender.

This is what I have:

How can I make it so that the backplate_single is root and btn is on it’s own bone that can move. (And then animate, but thats for another day…)

I already tried parenting the meshes to a armature, and in blender they moved with them, but I couldn’t export them. (I grouped the meshes and bones, then it said model had too many armatures. Mesh and collision model came out correctly.)

-snip-

Actually, try this. For each object, make a vertex group that uses all of the vertexes. Make sure these groups have different names from each other. After you do this, join the objects together. Any armatures you have currently, delete then and make a new armature and parent it to the combined object. Make 2 bones that are parented to the armature but not to each other. One of these bones is your root bone, the other bone is for your movable part. Parent the vertex group for the root part to the root bone, and the vertex group for the moveable part to the movable bone. This is doable in the vertex groups tab. The hierarchy should look like this at the end.

> Combined Object
> > Armature
> > > Bone 1
> > > Bone 2

I am now at this point, I cannot figure out how to parent vertex groups.

http://i.imgur.com/Lk6PgEt.png[/t]

So I exported it, and got the root bone (after removing $staticprop… ):
[t]http://i.imgur.com/yJOWBDg.png[/t]

And If I import the .mdl back to Blender:
[t]http://i.imgur.com/RQ71U18.png

There’s only one bone.

So I figured it out based on the imported smd structure:

http://i.imgur.com/DEqKQNJ.jpg[/t]

This is the structure that I used:
[T]http://i.imgur.com/JtOCUU7.png[/T]
I just grouped everything (except physmodel) together to be able to export.

Here’s the modifiers settings:
[T]http://i.imgur.com/B9OHIgd.png[/T]

However the compiler still says too many armatures, so I dont think this is the absolute proper way to do it.
If someone has any idea what I am doing wrong, feel free to post ideas.

[editline]edit[/editline]

[editline]edit[/editline]

Disregard that; animation exported correctly, it’s just that the HLMV.exe doesn’t show animations if you use the radio buttons. Instead just select the animation in the first box:
[T]http://i.imgur.com/LGPdeEW.png