Skeleton wrong compiling

I’m trying to make my skeleton (using Mario tutorial) for the ragdoll, but after the compilation skeleton were changed (why?) and I’ve got an “ERROR” instead of ragdoll in HLMV.

Probably a dumb question, but are the spine and thighs connected to the pelvis? Is the pelvis set as the root bone in the QC? If so, does the root bone have any vertices weighted onto it?

All bones are connected, like in the Mario tutorial. There must be bone called “Pelvis”, I think?
Here how I’ve connected hand and leg bones:

And here how I called the bones:

Try making a bone that’s not rigged to anything, but link your spine bone to it and make it your root bone in the QC.

Like that bone? (it was created after exporting ragdoll in .smd)

Nah, that’s just something that the importer does, create your own

Okay.

Well, I think I’m totally noob at ragdolling. :smithicide:

Did it work or not or what?

Naturally, no.

Do you model in 3ds max?

If so maybe you should take a look at my “Any Good Tutorials For Making A Ragdoll In 3ds Max?” Thread, It explains alot, though I still have not finished my own it does tell you what you need to do in basic.

If this is after compiling, let’s see your QC.

Yeah, QC please.

Problem is not in QC. Problem in strange exporting of the ragdoll. QC is simple because I’d took it from the Mario tutorial.

Couldn’t hurt to post it. :v:

Ok, here QC.



$cd "C:\Users\Владелец\Desktop\New Data\beta02"
$surfaceprop "flesh"
$modelname "engineerrus\New_Vegas\bennyjessica02.mdl"
$model "bennyjessica02" "reference.smd"
$cdmaterials "models\models
ewvegas\characters"

$sequence ragdoll 	"ragdoll.smd" FPS 30 		activity ACT_DIERAGDOLL 1
$collisionjoints "phymodel.smd" {
	$mass 60.0
	$inertia 10.00
	$damping 0.01
	$rotdamping 1.50
	$rootbone "Spine"
}


For the reference, are the bones weighted to the proper parts of the model? e.g. hand bone to hand, upperarm bone to upperarm, etc? Just to at least have the skeleton attached to the mesh in a way. And have you tried exporting the physmodel as a reference (as well as the reference itself?) Have you tried reinstalling the smd importer/exporter plugins?

I’m not sure what the problem is exactly, just throwing out ideas.

Change $rootbone “Spine” to $rootbone “pelvis”

Whatever the main bone that move everything.

Send me a file of this error also.
What was the error log also?

A root bone isn’t needed, as long as you have your pelvis bone as the root bone like nexus has showed above your good, but uh your picture doesnt seem to have a pelvis, well it doesnt matter really, but it can go, pelvis/spine/spine1

Ok, I’m understand, that it is the strange reaction of the exporter on the copyed parts of skeleton. It’s strange.