Skin turns out weird?

So i made a new skin, same way as yesterday but i colored the skin at some places and added a picture, why does it look like this in VTFEDIT? http://prntscr.com/6x9yan heres a pic of photoshop: http://prntscr.com/6x9yqu

Btw ignore lightbar, i just attached it to vehicel with weld :stuck_out_tongue:

Heres a picture of it ingame:

you need to fill the checkered are with a color

What are you talking about


right there, see how it’s checkered? that means empty

That’s not related, that’s just showing it with the alpha channel of the texture, it wouldn’t have any effect on how it shows up ingame.

oh ok then disregard me

U know how i can fix?

Actually he’s right. You’re importing it as a PNG, aren’t you? Hold control and click on your transparent layer and save it as an alpha mask, then fill the background in with an appropriate color that’ll prevent outlining (in this case your edges are black so fill the background in with black). Export as a tga before importing into vtfedit. Use $translucent in your material.

Can you link a youtube tutorial for that please? I don’t really understand that.

Hey it looks fine in vtfedit now but like this ingame: http://prntscr.com/6xn5p4

[editline]24th April 2015[/editline]

My fault, forgot to update the vmtr file with custom code, ill try again.

[editline]24th April 2015[/editline]

Hmm same thing again. VMT code:



"VertexlitGeneric"
{
	"$basetexturetransform" "center .5 .5 scale 80 80 rotate 0 translate 0 0"
	"$basetexture" "models/tdmcars/chargersrt8/skin2"
	 $translucent 1
	"$bumpmap" "models/tdmcars/shared/skin_normal"
	"$nodecal" "1"
	"$phong" 1
	"$phongexponent" 5
	"$phongboost"	2
	"$phongfresnelranges" "[1 1 1]"
	"$rimlight" 1
	"$rimlightboost" 0.5
	"$envmap" "env_cubemap"
	"$envmaptint" "[0.07 0.07 0.07]"
	"$normalmapalphaenvmapmask" 1
	"$detail" "models/tdmcars/chargersrt8/skin2"
	"$detailscale" "1"
	"$detailblendfactor" "1"
	"$detailblendmode" "2"
	"$colorfix" "{255 255 255}"
	"$phongfix" "{1 1 1}"
	Proxies
	{
		Equals
		{
			srcVar1	$colorfix
			resultVar	$color
		}
		Equals
		{
			srcVar1	$color
			resultVar	$phongtint
		}
		Add
		{
			srcVar1 $phongfix
			srcVar2 $phongtint
			resultVar $phongtint
		}
	}
}


[editline]24th April 2015[/editline]

Also a picture of updated photoshop file: http://prntscr.com/6xnc8t

[editline]24th April 2015[/editline]

Any idea?

You are still leaving the alpha channel (the checkered pattern in photoshop indicates there’s alpha) untouched. Alpha channel is used to create transparency in models, in this case, the whole vehicle body has transparency. To ‘fix’ that you’ll need to fill the checkered with a color, like white.

Ill try that, thanks.

And hey lonewolfie i see your browsing thread i used your tutorial maybe you can help?

Remove



"$basetexturetransform" "center .5 .5 scale 80 80 rotate 0 translate 0 0"


and



$translucent 1


from your VMT.

Also when you save your photoshop file, Save it as a .TGA and import that. PNGs are weird sometimes.

Also try setting your import options to this if you haven’t already

Slightly unrelated but from your in game screenshot it looks like you have the very old TDM charger model, check your downloads folder because it looks like some old server content is overrwiting it. (Its not what’s causing your skin issue though)

Now it looks like this ingame again, but this time the text etc isnt there. http://prntscr.com/6xa5kb

Hm, If you could upload your .psd to dropbox or something I could take a look at it

Ill try that :slight_smile: 5 min also my latest post was before i tried what you said, ill just see if it fied it first.

[editline]24th April 2015[/editline]

here: https://mega.co.nz/#!SMIU2IIZ!k2LstixwQREHjPrkUvitLpRXrKNbRG9zq-nQu6OSc9g

[editline]24th April 2015[/editline]

Wait! I might of forgot to reupload vtf, vmt file it works now! Thanks so much lonewolfie and any other that helped me! Any idea how i can make it so the text doesnt kinda go invisible when i turn on flashlight and point at it?

[editline]24th April 2015[/editline]

Also it might not look that good >:( Im bad at photoshop + its my first ACTUAL skin :smiley: