Skins not showing up at all

I just edited a skin for the Desert Eagle on Counter-Strike Source, I made the skin files into .tga, edited them and turned them back into vtf and vmt files. When I start up the game, there is no skin, just the hands. Can anyone enlighten me please! ):

Checkerboard? Invisible?

Get a screenshot

Invisible, just showing the hands, I downloaded a revolver skin for the deagle and tried to turn it blue, but when I put the vtf and vmts into the folder again, it was invisible.

post the vmt…

LightmappedGeneric/VertexlitGeneric?

Vmt of the original map1,map2,map3 or the edited versions?

Edited.

I don’t have VTFedit right now, (I’m on my Mac) so I’ll post the .jpgs.
http://profile.imageshack.us/user/wingedturtle/images/detail/#18/map3li.jpg
http://profile.imageshack.us/user/wingedturtle/images/detail/#18/map2io.jpg
http://profile.imageshack.us/user/wingedturtle/images/detail/#18/map1f.jpg

Like I said, It’s a revolver for the Deagle, so it looks a bit strange.

You Dont edit the vmt, you edit the vtf in any program save it as a tga open up vtf edit Save it as a .vtf and then put it in whatever folder.

Did I say .vmt? Sorry, I actually edited the .vtfs, I only replaced the .vmts with the new ones Vtfedit spit out after importing these jpegs that were previously .tga. I had to save them as .jpg to host them.
By the way, the vtfs are supposed to go with this skin:

Ah i see well let me show you a tutorial i just made i hope this helps :slight_smile:

Try to get VTFedit it really helps when i need to turn a .tga into a .vtf Simple and easy :smiley:

http://img188.imageshack.us/img188/289/part1v.th.jpg

http://img35.imageshack.us/img35/6554/part2s.th.jpg

http://img199.imageshack.us/img199/9803/part3y.th.jpg

http://img19.imageshack.us/img19/8480/part4w.th.jpg

http://img269.imageshack.us/img269/3697/part5g.th.jpg

http://img25.imageshack.us/img25/1358/part6y.th.jpg

Thanks! I have them saved as .vtf, and when I save them I get a set of .vmt files. Do I put those in the materials folder too?

hmmm well if it was part of the skin of the gun sure

[editline]02:24AM[/editline]

if it messes up try to get the vmts out lol

Thanks, I’ll keep trying. :smiley:

oh np :smiley:

-snip-

fuck you all, just tried to help here

Yes that’ll be your issue, the default VMTs spit out by VTFEdit are “LightmappedGeneric” which will only work on textures that use brushes (map textures), for models you must have “VertexlitGeneric” otherwise they will just show up invisible. There are other shaders you can use, but i’d advise against it unless you really know what your doing.

Hey Mangina Calm the fuck down