Skipped rendering frame because gfx device is in invalid state (device lost) [SERIOUS ISSUE]

The console repeats this message over and over. I can barely play the game because it’s running at 10 FPS and I know the cause of this drop in FPS is directly related to the messaged being constantly relayed in the console.

I’ve scowered Google for a solution to this issue, but I haven’t found a fix. Is anyone else having this issue? Does anyone know of a fix? I heard it may have something to do with sound card drivers? I really have no clue. Any help would be greatly appreciated.

Will provide more information if needed.

Post your specs, please.

I get the same thing in my console, but i’m running 110% fine.

same message when alt-tabing out of the game, no perfomance issues though

Config.cfg

I had this message appear multiple times before. It was whenever I would alt-tab the message would scroll. When I was in-game with console open, I would never see it, but I would quickly alt-tab, and it would appear.

Processor Intel® Core™ i7-4700MQ CPU @ 2.40GHz, 2394 Mhz, 4 Core(s), 8 Logical Processor(s)
System Type x64-based PC

Running Windows 8

[editline]3rd February 2014[/editline]

Posted specs

Video card and RAM, please. That’s just your CPU and your posts show your OS.

I heard that alt-tabbing was related to this message, however, this message spams my console even while I play the game.

[editline]3rd February 2014[/editline]

8.0GB PC3-12800 DDR3 SDRAM 1600 MHz
2GB NVIDIA GeForce GT745M Discrete Graphics

[editline]3rd February 2014[/editline]

Intel HD Graphics 4600

I had to Laugh when I read Intel HD Graphics, must not be a techy, that doesnt even come into play with a Discrete card…

Anyhow

Your System speccs well exceed this game I would lean towards updating Drivers Nvidia, Realtek, and chipset driver from intel… Dont just update them remove old ones before installing new ones dont reply on the installer to do that correctly for the nVidia and realtek…

I would urge others running Windows 8 to post if they had any wierd problems, I build PC’s for a living and have seen windows 8.1 update screw up many computers programs and requiring reinstalls…

If you recently updated to Windows 8.1 you should know that 8.1 is not a standard update every hardware manufacturer had to create drivers specific to windows 8.1

Use the Nvidia panel to make sure Rust is using your discrete card and not the Intel HD.

Rust and Intel integrated graphics get along about as well as water beds and hedgehog cannons.

This laptop is relatively new and I’m almost positive everything is up to date, but I’ll still check.

[editline]3rd February 2014[/editline]

Do you mind elaborating on how to do this?

New computers Never have the latest drivers, the disks that come with them are almost always 6+ months old…

Read Previous post regarding windows 8.1

I’m running Windows 8.

That’s a bit ignorant, the integrated definitely matters, not so much the model but the fact that it may default to integrated.

Like elix said.

Not relative to your problem but it bothers me slightly, turn vsync on.

[editline]4th February 2014[/editline]

And no vsync doesn’t cause frame drops, that is a myth.

Think of it as a little man in your GPU that holds the next image to be displayed, his name is back buffer. If this little man is patient and has vsync turned on he waits until your monitor is refreshed before handing the next image over to his good friend frame buffer, frame buffer then draws the image to the screen.

Now, if back buffer is not patient and has vsync turned off he will force all of the images on frame buffer as fast as he possibly can, frame buffer can’t possibly keep up with this so he gets angry at back buffer and starts tearing up images to spite him. Because of this their once beautiful friendship turns into a hatred for one another.

So next time you go to turn off vsync, think to yourself, do I want to destroy a beautiful friendship?

Edit: oh it’s a server.

Simple fix for this is to add -batchmode to the server’s shortcut.

ie: Right-Click server.exe and make a shortcut. Right-click the shortcut and select properties. In the Target box add -batchmode like this:
…/rust_server.exe -batchmode
If your path includes “quotes”, put -batchmode outside the last quote after one space.
“…\rust_server.exe” -batchmode

How exactly do I do this?

Where is server shortcut?