skybox alignment

i have seen the tutorials but i am still a bit confused on making the skybox fit around the map so it doesnt cast a shadow on the map.

the sky camera scale is 20.

Did you try this tutorial? http://www.interlopers.net/tutorials/1839

Alternate solutions for your shadow-disabling needs include turning the relevant brushes into func_brush and setting “Shadows” to No, or adding -noskyboxrecurse to vrad (this will prevent all shadows coming from the 3d skybox from affecting the main map).