Smoothing Groups in Blender?

So I’ve recently been learning how to bodygroup models myself (loosely following this tutorial) and while I was successful in getting my first weapon recompiled and working in-game, the smoothing groups appear all messed up. Pics below.

(The model in question is Hyper & Noodum’s MP7 for Insurgency)

Bodygrouped model:

http://dl.dropboxusercontent.com/s/l44w3cydvbixu9b/mp7gmod.jpg[/t] [t]http://dl.dropboxusercontent.com/s/loplwb8zwkrlcaf/mp7sfm.jpg[/t]
VS. Original model:
[t]http://dl.dropbox.com/s/sx4on2lel0ekaec/mp7.png[/t]

I’ve definitely seen this issue before, so I assume it’s a common one, but so far I haven’t come across a solution. Hoping someone with more in-depth knowledge of Blender can help me with this.

After importing the model, I used Blender’s “Auto Smooth” feature with an angle of 28 degrees. In lieu of the author’s own smoothing groups, I hoped this would be good enough. Apparently not.

[t]http://dl.dropboxusercontent.com/s/jdytwdcmqa2iake/mp7blender.png

Is it possible to create/edit smoothing groups in Blender? I’m aware that 3DS Max lets you do this, but Blender’s only equivalent seems to be the Edge Split Modifier, which tends to disrupt the geometry of a model by replacing a single vertex with two separate/coterminous vertices. And since Auto Smooth is only a rough approximation at best, nowhere near the quality of the author’s own smoothing groups, I’m at a loss for how to proceed. Are the author’s smoothing groups somehow lost along the way, or is it just that Blender doesn’t recognize/import them? Does the auto-smoothing even carry over throughout the SMD export and recompile, or is it lost somewhere along the way? (Seems like it’s doing less than nothing.) Or does the problem have nothing at all to do with the smoothing groups, but rather something else entirely? And last but not least, can the issue even be solved in Blender, or should I consider downloading 3DS Max?

Any and all assistance would be appreciated. Thanks in advance.

Set Auto Smooth to 180 and then use edge select mode. The tools you’re looking for are on the left, under “Shading/UVs” in edit mode.

http://i.imgur.com/URPjj0Q.png[/t]

“Smooth” and “Sharp” for faces, edges, and vertexes. Select the edges you want and click “sharp”.

[t]http://i.imgur.com/cw9NNNo.png[/t]
[t]http://i.imgur.com/32OIlm4.png

Hope this helps! Have fun!

EDIT:

Also, it’s occurred to me that if I remember correctly, there’s an import option that deletes the smoothing groups, and that is on by default for some reason.

EDIT 2:

“Preserve SMD Polygons & Normals”, and it’s disabled by default.

You can preserve the smoothing. There’s an option that you can tick on the lower left panel when you’re setting up your import. It does make the model harder to edit, however.

There are no smoothing groups in Blender. Instead, you mark needed edges as sharp, then add Edge Split modifier to mesh.

Thanks gents, I completely missed that checkbox the first time around. I re-imported the model (this time with the “Preserve SMD Polygons and Normals” box checked) and there was an immediate improvement. Although there are still some hot spots where the smoothing looks dodgy, so perhaps I’ll follow your input and try my hand at re-smoothing the model.

[img_thumb]http://dl.dropboxusercontent.com/s/y9j2dz2lubxr4ly/preservenormals.gif[/img_thumb]

Of course, now that the polys are disconnected, editing them is a lot more difficult. Any suggestions? I’ve heard that a good work-around is to import a second, smooth-shaded model and somehow copy the polygon selections from the second mesh. Not that I have the slightest idea how to accomplish this, mind you.

Edited:

Problem solved! I just switched to Face Select Mode instead of Vertex Select Mode (Ctrl+Tab > Face) so instead of selecting all the individual vertices I can just click to select an entire face without having to deal with coterminous vertices.

Thanks again!