SNPC Model Animation?

Hello, I have created a model including 3 sequences. Walk, Ragdoll, and Idle. I can see them properly with the animation tool in Garry’s Mod, but when I try to turn it into an SNPC, it doesn’t play animations. I know it is not a fault of the code because as a test I have seen that other models have worked with it. What I am getting at is that the model does not walk, it just t-poses.



$sequence ragdoll "phy.smd" ACT_DIERAGDOLL 1 fps 30.00
$sequence idle "idle" ACT_IDLE 1 fps 30.00
$sequence walk "run.smd" loop ACT_RUN 1 fps 30.00


So why is this happening, technically it is supposed to walk. Any advice? :v:

Bump :yarr:

Because Garry’s Mod

:v:

So when you turn it into an SNPC, are you using self:SetSchedule()?

What you did should work but since the GMod13 update, fucked up

Thanks for the reply, I think I may have found it guys, I will report back soon and close the thread. Alittle busy today, so I won’t be able to check much because it’s my Birthday :dance:

Edit:
Alrighty, so I switched the SNPC code to use the NextBot code and boom, it worked. Hoping to release soon :smile:

:dance: