Solution to everyone who suffer from game crash with Nvidia!

Got a Nvidia card?
suffer from game crashes\pc freezes\black screen of death?
here is a solution for you all!
After months of stubborn tries, i finally did it, the game works!

  1. Update you BIOS (search on google on how to)
  2. Open Nvidia control panel (in the corner at the bottom of the screen where the windows clock is)
  3. Click “Manage 3D settings”
  4. Choose the “Program” tab
  5. Search for rust in games list, if you dont have it, click “add” and find the rust.exe (in the steam folder > steamapps)
  6. Set “Antialiasing - Gamma correction” to Off
  7. Set “Antialiasing Mode” to Off
  8. Set “Texture filtering - Negative LOD bias” to Clamp
  9. Set "Texture filtering - Trilinear optimization to Off
  10. Set “Threaded Optimization” to Off

save the settings > enjoy!!!

P.S
same thing works for Kerbal Space Program!