Solution to the Failed Connection after 4 tries problem.

I found the solution to the Common Problem.

Ok, guys, this it what I want you to do… I’m finally able to host servers again by doing this;
First forward your ports.
Second create a multi-player match.
While In this match type sv_lan 0
And type heartbeat.
Finally while in-game on the multi-player match hit ESC and don’t disconnect but click Create multi-player match again. After you did this the second time people should be able to join… This worked for me… And, I hope it works for you.


Don't forget to turn off your firewalls. Even Windows I didn't get it to work until I turn off Windows.

I have created a server and if you wanna test this out, the server name is: Syphens listen server
It will be up when I’m not working on a project… :smiley:

Please note: This is for the listen server I’m not sure if this’ll work for dedicated yet… :smiley:

While you try it out, here’s A soothing image of my friend and a tower of balls in the background.
http://img149.imageshack.us/img149/6025/gmflatgrass0002wt3.jpg
I won’t embed… :smiley:
:siren: And once more Forward you Half-life 2 steam ports and your Half-life 2 steam server ports:siren: Use www.portforward.com

I really hope this works for you guys…

Please follow the instructions to the letter…


If when starting the second time it says at the beginning of the list  "Starting Local Server" or something close you did something wrong!

**
If you get an “Establishing Connection to Server” you did it all right… A+ for you… :D**

Do you have to do this EVERY time? :frowning:

No, only if you restart your computer… Well at least for me not every time. :smiley:

Your part of the forumer support?, Darling

No I’m not. But, I figured this out and wanted to share. :smiley: :3:

Ah ok :3:, Nice find though i’d never had figured that. Seriously i woudn’t

Please share this thread with others that have the problem… :smiley:

It still didn’t work for me, and I got:

Connection to Steam servers successful.
VAC secure mode is activated.
No pure server whitelist. sv_pure = 0

in the console. My friend still can’t join, and I can’t join his. I’ll turn my firewall off but its window’s firewall. I’ve never had to forward my ports in 10 and my step dad won’t let me touch the router. I can’t even see my friend’s server and he port forwards.

Oh wait. It didn’t work. The guy that joined got the error last second before getting on.

Sorry pal, Our relationship is over

Edit:

I go re test it anyway.

That’s weird, it still works for me. Why is it working for me and not you guys? I must figure this out… I’ll get back to you. As you wait…
Watch me mess around on my server spinning my friend polar_bear.
http://www.wegame.com/watch/Spinning_your_Friends/

Edit:

What error did he get?

Tell me it word for word if you know it?

The only fire wall I have is window’s… which isn’t going to do crap. I didn’t have to port forward before the big orange box release. Should I even bother trying to turn off the fire wall?

And I’ve had “Establishing Connection to Server” before, on my first try after starting up gmod.

Turning off the firewall is essential… Even if it’s only windows…

You can establish a connection but with the firewall no one will be able to join… Do I have to record a video showing you guys what to do?

Ugh I’ll try it when my friend can play again. Honestly though, I never did any of this stuff before the Orange Box (GMOD 11) update.

Edit:

k turned off my fire wall and he got the same error…

Type heartbeat? Is that what I’m missing? By jove!

Testing.

Hmm…
This is weird…
How come it worked for me on the first try…
So many question I need to answer…
I was able to make it so anyone can join my server… This is really weird…
We must brainstorm…

Is it because I don’t port forward? (I’m not allowed to). Like I’ve said though, I could host in 10.

And I do type in heartbeat before making the new server.

Sometimes yes, sometimes no. UPnP “can” negotiate an external port for your server and handle the port forward stuff, assuming that the router supports it, is enabled, and you have UPnP on your box.

A usual indicator would be that your friends would see the port number as something rather high up there, not your usual 27015 and such.

Well my friend who does port forward (to host another game), his server doesn’t show up. It didn’t show up in 10 either.

Nothing

Yet another one… Does this only work with me?