Some error on Cannonfodder's StudioCompiler since source engine was updated.

http://img686.imageshack.us/img686/646/81512382.jpg

http://img692.imageshack.us/img692/6913/47464632.jpg

http://img710.imageshack.us/img710/9188/84109410.jpg

Decompiler works, but that compiler doesn’t work.

:frowning:

What should I do?!

Have you reset game configurations for each engine version in the SDK, and refreshed SDK content afterward? I had to do that to get GUIstudioMDL working, and to be able to map for CSS.

Show the QC

how to reset game configurations?

[editline]07:21AM[/editline]

I need not .qc files to compile them with that compiler.

That GUI frontend is very outdated, I would suggest finding a new one like “GUI StudioMDL” or jumping on the Valve developer wiki and reading up on making proper qc’s.

Then I recommend writing one. Since the bad command error usually happens with a bad QC (I’ve seen it show up on badly written jigglebones). It’s possible that the program is creating the QC in some odd way, which worked fine for the older version of the compiler, but with the upgrade it may have changed.

GUIStudioMDL and .qc is the best way for me, studiocompiler isn´t working, I´am getting same error with or without .qc

I also recommend GUIstudioMDL. It’s much simpler to use and making your own QC file with Notepad++ is far easier. You have more control and you don’t have to worry about the compiler fucking up. GUIstudioMDL has never fucked up itself. The only time it fails to compile is if my SDK files are messed up (in which case it won’t even start compiling), or if I made an error in my QC file. It’s just…reliable.

Anyway, to reset your SDK game configurations, you need to load up SourceSDK and hit “Reset Game Configurations.” Do this for each engine version (you select it in the little drop down box at the bottom of the SourceSDK window). This should correct any configuration issues that the recent engine updates may have caused. If that doesn’t fix it, load up SourceSDK again and click “Refresh SDK Content.” This process takes a while but it basically completely renews all the SDK files in case something got broken from an update.

Remember that process as there’s eventually going to be some kind of big update down the road that may break the SDK files for you.