Some problems on making a gma work

I’ve been trying to compile a simple gamemode for now, just to make sure it works. However, when I compile it, it doesn’t appear in the menu and it isn’t switchable from the console command gamemode.

The structure of the whole thing follows the format that is mentioned on this and this part of the Garry’s Mod Wiki.
This is my folder structure, where everything is the folder that contains all parts of the addon:
everything\gamemodes\backtick\gamemode\cl_init.lua
everything\gamemodes\backtick\gamemode\init.lua
everything\gamemodes\backtick\gamemode\shared.lua
everything\gamemodes\backtick\backtick.txt
everything\gamemodes\backtick\icon24.png
everything\gamemodes\backtick\logo.png
everything\addon.json

gmad.exe seems to compile it just fine, but when I put the new .gma file into the addons folder, it hinders from showing.

everything\gamemodes\backtick\backtick.txt contains the following information:


"backtick"
{
    "base"  "sandbox"
    "title" "backtick"
    "maps"  "^bt_"
    "menusystem"    "1"
    "settings"
    {
        
    }
}

everything\addon.json has the following information:


{
    "ignore": [
        "`*"
    ],
    "tags": [
        "roleplay",
        "realism"
    ],
    "title": "Backtick",
    "type": "gamemode",
    "workshopid": 401889068
}

.gmas from addons/ folder do not load if they are no in subscribed list. Put the .gma inside another folder in addons/, for example addons/gmas/mygma.gma.