Something incredibly screwed up is happening to my Gmod.

Okay. I’m making this thread in hope if maybe anyone can halp me solve this.

So…
My gmod is a bit unstable it seems, loading spawnicons and sometimes spawnig stuff can make my game crash. Sometimes it’s a real pain in the ass.

That wouldn’t be an awfully big truble, but today i loaded up gm_atomic, and i was shocked.
I mean really. See for yourself.

http://img683.imageshack.us/img683/7404/gmatomic0000c.jpg

That’s a problem right there.

Also, models i spawn, are not showing up. Just the shadow, and nothing else. I can grab it with the physgun, which is “invisible” too but i can’t see it except the shadow.
Some models/entities/vehicles/npc’s do spawn normally, i tried it out. The ep2 hunter, kleiner, the jalopy, these all work.

Also, i have other minor problems, but those are really minor, so i won’t post them for nothing.

Yesterday, there weren’t any problems. Gmod was jsut fine. Well except the “unstability”.
But why it’s making things like these??

Please, help me.

Uh, have you tried verifying the files?

This was my first thought

IF that fails,
try defragging your files (I dunno, I’ve seen weird things get fixed by defragging :confused: )

Oh wait, it may be a problem with the map.

OP does shit work on gm_construct?

The problem on gm_atomic is the skybox texture missing/being corrupt, thus being drawn invisible for some reason instead of the purple/black boxes. This causes everything to be redrawn and causes that weird view.

I’ve tried other maps too.
For instance, rp_apocalypse(similar to gm_atomic) doesn’t screw up like that, but if i get too close to props and some map props, they disappear completely, and when i get farther, they reapper.
Also an error shows up saying “not enough memory (operation 2 /or what//)”.
It is very strange, because like i said, nothing like that happened before.
Now the spawn icons were also f*cked up, some of them were black. I tried to spawn an entity from SG-mod, and it crashed with an error message what said

              "failed to lock vertex buffer in CMeshDX8::LockVertexBuffer"   

And please explain how you mean “veryfing” the files and “defragging” them, i’m a complete n00b at these.
(And i’m just learning english, so if it’s something easy, i haven’t heard of it before.)

LIBRARY > Garry’s Mod > Properties > Local Files > Verify integrity of game cache…

Okayy, i’ve found it. Doing the verification now.
Fragmentation is at 0%

Ok.

What Source Games do you own? (And which of those games do you have installed)

If he didn’t own the Source games needed it’d just come up in the checkerboard black and pink
or a big ass Error sign…

It doesn’t if the material fails to load or gets corrupted, And it probably fails to load because of
failed to lock vertex buffer in CMeshDX8::LockVertexBuffer
You are running gmod in -dxlevel 80 or 81, What videocard do you have, and how hot does it get?
It either is dieing or simply can’t handle gmod.

Well that two maps seem to not work at all. I also tried out another map, gm_area51, which is an awesoem build map, and nothing seem to happen what did happened on the two other.

I have ALL source games, from cs:s to team fortress 2, including all of the EP’s of hl2, and of course hl2 itself.

My PC specs are:
AMD Athlon II X2 250 Processor, 3.00 GHz
2 GB RAM
Windows 7 32 bit
ATI Radeon 5600 series video card.
And i have a shitload of free disk space on the hard drive.

And the vid card seems not to have problems with heat while playing gmod. It’s warm, but not HOT.

EDIT:
Forget i said anything. It does the same ong gm_salvation and other maps. I want to spawn something, an the game crashes. Gun disappearing.
Error messages when i enter a map.

What the FUCK is going on?!
It really didn’t do anything like this before, why the hell it’s doing it now?

Should i get more ram?

You’re ram’s fine.

Does it fuck up on gm_construct or not?

It does.

Did you try reinstalling gmod?

It seems like the skybox textures are missing/ not working. That also happens when you create a map in hammer without all the 6 walls of a cube. Could be an addon that just changes the skybox textures.

Reinstalling gmod is the one thing i really want to avoid.

-snip- late