Something strange is happening to my water

I haven’t come across this problem before. I use cubemaps, I’m not using a cheap water texture, there isn’t a viscluster right above it, there’s no leak, etc…
When I move away from the water, it goes all solid looking and a noticeable outline of the geometry underwater becomes visible in a buggy way. Please help?

http://img201.imageshack.us/img201/244/gmfalcon4lake0000.jpg

Are you using a water_lod?

I have one, yes. Should I increase the distance of it?

Yes.

I will check this out tomorrow to see if it works. Thanks.

It’s still doing it. Hasn’t fixed it at all. ):

Try another water texture or check if it looks the same in another game.

I’ve tried many different waters.
It just turns cheap when I move away from it in specific directions. It’s like it thinks I can’t see it when I can.

What graphics card do you have?

Only your map or every map?
If every map, Firegod is most likely right about it being a hardware problem and not the maps problem.

It looks like when you used to turn the flash light on and the water rendering would freeze and move with the camera.