Sorry about this.... HL2.exe has stopped working...

Ok well i have windows vista and my guess thats my current problem. I have had garrys mod for quite some time now, and i stopped playing for about a year or so, and before that it was find. Well now it seems that randomly when im building something it just freezes and seconds later i get the message hl2.exe has stopped working, i tried what coopmaster said but still same problem. Any help please.

Here are my specs…

http://img43.imageshack.us/img43/4594/ss11w.jpg

download and screencap and post

Is this what you meant

http://img43.imageshack.us/img43/3259/ss22.jpg

I had this problem too, it’s an easy fix though.

open steam>go to MYGAMES> highlight garrysmod>at the bottom right click PROPERTIES> click set launch options. then paste this in there.

-dxlevel 70 -mat_forcehardwaresync 0

then hit ok and try it out.

thanks for trying, if anything it made the whole game run worse :confused:

by the way now when im playing in servers, it looks like this and runs horribly

I get this problem too, all I have to do it look away form the stuff I spawned, then Hold Q, but I know there’s a launch option code that fixes it, i tried looking but couldn’t find it, It’s somewhere her on the help forums, so goodluck, and If I find it I’ll post here right away.

thank you very much man, i would really like the game to not crash and work properly lol


-dxlevel 81 -mat_forcehardwaresync 1

?

-mat_f…ync 1 is there to undo the setting it to 0.

-dxlevel 81 will run it at DirectX 8.1

if i use


-dxlevel 90 -mat_forcehardwaresync 0

(its -dxlevel 90 for me cuz i have directx 9.0)

i can play gmod but i don’t have my addons, gamemodes & maps ingame but they are in my folders.

and i have directx 10
what do i do?

Source doesn’t run on DirectX 10.

-dxlevel 90

Don’t fuck with your DirectX settings, it’ll be pretty obvious if DirectX is the problem.
Windows Vista has NOTHING to do with your crashes.

Either something with your drivers are fucked, or your Garry’s Mod folder is corrupt. Re-install Garry’s Mod, if it still does it, re-install your graphic drivers.

How exactly would that work?

There’ve been plenty of problems where it wasn’t obvious it was a DirectX issue, but it was a DirectX issue nonetheless.

well everything is working quite well now, thanks!

But the only problem is when i click an npc that i cant spawn, the message saying “Sorry, you cant spawn that npc” stays stuck in the middle of my screen, and the mouse disappears and im stuck and have to reboot gmod

Have you tried pressing Escape?

I try everything, no button works, i always have to restart the damn game :frowning:

Im desperate please help. I got everything working, i even played for about 9 hours. And now when i try to join servers, as soon as it gets to the sending client part of the load screen the game crashes and i get the hl2.exe has stopped working

You can’t solve the “Can’t Spawn THAT NPC!” issue. Garry fucked it up.

Well my other issue im pretty sure is fixable, i just dont know how

Actually if you use your friends list and join their Garry’s mod game from there you can get out of it