Soundscapes not working correctly

I’ve had this problem for a long time now and it seems to only happen from soundscapes in maps. Whenever I enter an area on a map that would normally play a soundscape with a sound that is not native to garrysmod, (for example, playing music when entering a certain part of the map, purely clientside), my game, rather than playing the sound file, plays some weird ass repetitive sound that honestly sounds like clothes tumbling inside a dryer.
I have no idea when this bug started but it is incredibly annoying.

I have tried verifying game cache, deleting my entire sound folder in garrysmod (both downloads and normal sounds folder), and I have changed my sound settings in garrysmod to anything and that has not fixed it.

This is a screenshot of my audio specs in speccy (not much to see)

https://dl.dropboxusercontent.com/u/5898394/sound%20SHIT.png

I have no other sound problems outside of garrysmod.

If anyone has an idea of what might be wrong, or you need more information, please ask/tell me.

Fixed the issue, the issue was with the soundscapes loading in the incorrect order. Unmounting HL2 EP1 fixed it.