SOURCE •• Distorted Model Animations

I’ve been working on a custom model for the SOURCE engine to use in an upcoming map project. I’m now onto the animation phase, and have tried exporting the basic idle sequence with success.
The problem I’m now having has to do with my animated sequence. I’ve made a basic animation for the creature I’m modelling to do some basic walking.

While this is a still image, you can get the gist of what I’m shooting for; the creature’s legs move forward and back and its mandibles and tail sway to and fro as it moves. When I run the sequence in Blender, all is well. The problem I’m having is when I export it for testing. While not completed, I wanted to export the one animation along with the base model to make sure that the animations will work. I launched HLMV and loaded the model. Aside from missing textures (which doesn’t happen when viewing it in HAMMER), the model loads up fine. When I switched the sequence from Idle to Moving, however, this happened…

Again, while it is a still image, you can see what’s happening. The creature’s legs move way out of line. They sway from side to side to an extreme, and the tail distorts while moving. The only part of the model that moves correctly are the mandibles.

Going back to the first image, you can see that the Source SMD addon detects two exportables: BOSS.smd (the base model) and ArmatureAction.smd (the skeleton). Since I could only use one SMD for the sequencing in the QC file, I first tried the BOSS.smd and renaming it to Moving.smd, but that only made the exported model stay static in HLMV. I then tried to use the AmartureAction.smd and now the creature is moving way out of line. Here’s my current QC file.



$modelname		"Test/Test.mdl"
$body mybody		"reference.smd"
$surfaceprop		antlionflesh
$cdmaterials		"models/Test"

$scale			1
$sequence idle		"idle.smd"
$sequence moving	"anims/ArmatureAction.smd"


Is there something I’m doing wrong with the SMD files or the QC file?
Thanks in advance for the help.