Source SDK Error - MountAppFilesystem() failed with error 4: Bad launch configuration

I don’t really know if this is the right place to post this, but I’m honestly just so tired of this stupid error that I don’t even care anymore.
I have a simple TF2 hat model in OBJ format that I want to use in Source Filmmaker. I tried using itemtest. itemtest has worked perfectly fine in the past, including times before and after the SteamPipe update, but now it crashes around the geometry file selection screen every time.
I used Blender to create an SMD, and I have a simple setup with all the files I need to use studiomdl, I think, but I think you’ll find that whether I have all the files I need is irrelevant to the problem.
My QC file:


$cd "C:\Users\Pitzik4\Documents\glasses"
$modelname "player/items/scout/timspecs.mdl"
$model "body" "scospecs.smd"
$cdmaterials ""
$hboxset "default"
$hbox 0 "bip_head" -3.400  -3.375  -4.976  3.400  0.000  1.583
// Model uses material "models/player/items/scout/timspecs.vmt"
$surfaceprop "metal"
$illumposition 1.878 0.000 1.483
$sequence idle "idle" fps 30.00
$collisionmodel "phymodel.smd" {

	$mass 0.0
	$inertia 1.00
	$damping 0.00
	$rotdamping 0.00
}


I tried using GUIStudioMDL, but it gave me the error in the title:


MountAppFilesystem() failed:  SteamMountAppFilesystem(4294967295,4294967295,0x403ffcac) failed with error 4: Bad launch configuration

I Googled the problem for hours. A few times I saw people say, “I have this error. NVM fixed it.” How infuriating.
I ended up reinstalling Source SDK, including deleting sourcesdk and sourcesdk_content. The problem remained.
I Googled for maybe another hour. “I have this error. NVM fixed it,” was showing up even more than before now. I swear on the thankfully unexploded state of our Sun that I won’t do that.
I ran TF2 and verified the integrity of its game cache many times.
Interestingly, when I tried double-clicking vconfig.exe in bin\orangebox\bin, it gave me that same error.
I tried using studiomdl straight from the Command Line:


studiomdl -nop4 -game "C:\Program Files (x86)\Steam\SteamApps\common\Team Fortress 2	f" "C:\Users\Pitzik4\Documents\glasses\mdldecompiler.qc"

Same error. I Googled a while more. I clicked every single non-purple link this time. There was no useful information at all. So now I’m making my own post about it.
I am sorry to both the reader and to myself if I did not provide sufficient information here. It’s 1 AM right now. I’m going to bed now in the hopes that there will be an answer here tomorrow, though there probably won’t be. So, could somebody please help?

Alright. I didn’t successfully compile a hats for TF2, but I did get my model in SFM, and I promised I’d tell you how. I just set GUIStudioMDL’s EP1 path to steam/steamapps/common/SourceFilmmaker/games/bin and compiled the hat.
EDIT: I’d still really like to know how to solve this problem for future TF2 Workshop submissions!