Source SDK error

I configured gmod( Read it up on wiki), then suddenly when I go to run it. It says Setup file ‘gameinfo.txt’ doesn’t excist on ‘g:\Steamapps\user\garrysmod\garrysmod’. But drive G doesn’t even excist.

http://img692.imageshack.us/img692/4571/erroryz.png

Anyone got any ideas?

Just use the ep2 configuration if you have it.

But if you really want to use gmod be my guest.

You set your Game Directory to $SteamUserDir\garrysmod\garrysmod right?

Yes, thats what it says.

It may be a windows 7 problem, I’m not sure as I use vista (still :suicide:) Have you tried restarting steam or your computer?

No, but ill try that now.

Edit: Nope, it still fails.

I tryed using the EP1 engine, but my grid didn’t show up. And people said to use EP2, so I am. Then this came up.

Well gmod uses the orange box engine (or ep2 engine, whatever) so that was probably why.

I would just use the ep2 game configuration, its much quicker to launch, and play test. You will have a clean copy of a game without a lot of addons slowing it down.

If you don’t have it, try adding me on steam, I can help you from there.

I found the problem, in windows XP the drive steam was installed on was drive ‘G:’, then after I installed windows 7 it renamed it ‘E:’. So I had to go in a change all the settings to tell it, its on drive ‘E:’. But if windows 7 allowed me to change my drive to drive ‘G:’.

It would have been much easier!