Source SDK won't make a.bsp!!!!11

I am making a mod for portal, I am on the first testchamber, but when I compile it, it send me STRAIGHT to the menu, rather than loading the map(I don’t have “Don’t run map” checked).
here is my log:

** Executing…
** Command: “c:\program files (x86)\steam\steamapps\irishhawk98\sourcesdk\bin\orangebox\bin\vbsp.exe”
** Parameters: -game “c:\program files (x86)\steam\steamapps\sourcemods\Portal21” “C:\Program Files (x86)\Steam\steamapps\sourcemods\Portal21\maps\puzzle1.vmf”

Valve Software - vbsp.exe (Jul 7 2010)
2 threads
materialPath: c:\program files (x86)\steam\steamapps\sourcemods\Portal21\materials
Loading C:\Program Files (x86)\Steam\steamapps\sourcemods\Portal21\maps\puzzle1.vmf
Brush 19145: FloatPlane: bad normal
Side 0
Texture: METAL/METAL_LIFT001

** Executing…
** Command: “c:\program files (x86)\steam\steamapps\irishhawk98\sourcesdk\bin\orangebox\bin\vvis.exe”
** Parameters: -game “c:\program files (x86)\steam\steamapps\sourcemods\Portal21” “C:\Program Files (x86)\Steam\steamapps\sourcemods\Portal21\maps\puzzle1”

Valve Software - vvis.exe (Jul 7 2010)
2 threads
reading c:\program files (x86)\steam\steamapps\sourcemods\portal21\maps\puzzle1.bsp
Error opening c:\program files (x86)\steam\steamapps\sourcemods\portal21\maps\puzzle1.bsp

** Executing…
** Command: “c:\program files (x86)\steam\steamapps\irishhawk98\sourcesdk\bin\orangebox\bin\vrad.exe”
** Parameters: -game “c:\program files (x86)\steam\steamapps\sourcemods\Portal21” “C:\Program Files (x86)\Steam\steamapps\sourcemods\Portal21\maps\puzzle1”

Valve Software - vrad.exe SSE (Jul 7 2010)

  Valve Radiosity Simulator     

2 threads
[Reading texlights from ‘lights.rad’]
[53 texlights parsed from ‘lights.rad’]

Loading c:\program files (x86)\steam\steamapps\sourcemods\portal21\maps\puzzle1.bsp
Error opening c:\program files (x86)\steam\steamapps\sourcemods\portal21\maps\puzzle1.bsp

** Executing…
** Command: Copy File
** Parameters: “C:\Program Files (x86)\Steam\steamapps\sourcemods\Portal21\maps\puzzle1.bsp” “C:\Program Files (x86)\Steam\steamapps\sourcemods\Portal21\maps\puzzle1.bsp”

** Executing…
** Command: c:\program files (x86)\steam\steam.exe
** Parameters: -applaunch 400 -game “c:\program files (x86)\steam\steamapps\sourcemods\Portal21” +map “puzzle1”

We have a question mega-thread …

Its because you put a space in the name of you map.

No I didn’t , it’s the format on this page, it caused a space.

Error opening c:\program files (x86)\steam\steamapps\sourcemods\portal21\maps\puz zle1.bsp

Well, its not able to read the vmf obviously.

Why not?

try hitting reply and the spaces are gone

Brush 19145: FloatPlane: bad normal

That.

Yeah it was a bad brush, i dont know what made it bad, but it was a lift. Thanks, guys

Please, PLEASE use the questions megathread next time, if you can’t get proper help there THEN make a thread.

-Snip-
Worst English ever

Use that.