Space Build 3: Help/Tips Thread

This thread is completely dedicated to Space Build 3, and giving tips and assistance to players. If you have any problems with Space Build 3, or have any questions, you may post here. I hope that many skilled Space Build players will watch this thread, and help others. If you are a “Wizard” in Space Build, Lua, Wire, or anything related to Space Build, please watch this thread. Also post any tips you may have, useful information, tactics maybe, or anything alike.

 Please, no Arguments, we need to save space for people who are actually using the thread. If you need to argue, use private messenger instead of clogging the thread with useless crap. Also, tips do NOT include exploits, so don't post them here. Other than that, post away!

For anyone that wants to build a hover drive transit device, or teleporter, on Gm_Gooniverse, but is too lazy to get the coordinates, here they are. They are ordered in the following order
X
Y
Z
Plug these into a constant value, hook THAT up to the x y z values of the hover drive and there you go! If you want to have Multiple Co-ordinates, i would suggest using D Latches and such, or you may use 3 wire inputs for each planet, which i do not suggest. Use a pod controller, and wire the clk output on each D-Latch to any series of buttons on the pod controller. There are other ways to do this that i am aware of, but do not know exactly how to perform. If anyone knows a more efficient method of doing this, or just another method at all, please post a reply to this post.

Earth

-10575.302
-4773.531
-7900

Kobol

9484
8462
7217

Combine moon

-628
149
4667

I will Edit this post as i get more co-ordinates.

How do I fix the fact that SB3 gravity plating is broken?

Explain your situation in more detail. How is it “Broken”. See if you can get me some screen shots. We can’t help you unless you tell me EXACTLY what is wrong, and some more information such as console errors, or maybe the Popup on the HUD that you see above you shows some random crap like a bunch of numbers and the # symbol, explain.

The tool appears to function regularly, it just doesn’t do anything. Applying it to a prop has no discernible effect at all. Haven’t changed anything in my installation except regular SVN updates and Gmod updates. Works fine in SB2.

Hijack the tool from SB2 over in your SB3 folder :p?

-snip-

No dice, same thing. Only difference is the tool moves from the CAF menu to the regular tool menu.

Update your SVN once again, get the newest sb3, ls3, rd3, everything.

What do you suppose the first thing I did was? Everything’s up to date.

The thing is, mine works fine o_o

Ok, WTF!!!
Where did the svn links for space build go? its completely disappeared. the only one left is sbmp. i hear that garry shut down the forum and destroyed all evidence of the mods existence, but i don’t know.
-EDIT-
found some links
http://nebtown.pbworks.com/f/SB3AddonsJan10.zip
download this and update each folder with tortoise SVN, then drop them in the correct folders.

Or you could just use the official website, snakesvx.net

@Alpha:

I did that, but the outside no-gravity feature is not working. Also, some stuff is also not working (I just get an error when I try to use some things).

Some folders might be conflicting? Dunno. Mabye Its like when you play prop hunt and move to Sassilization afterwards. Shit hits the fan.

Outside no gravity? If you mean outside of a structure or prop, that feature doesn’t exist. The gravity is enabled in a radius that you set it to. So, say i set the radius to 3000, everywhere 3000 units away from the gravity regulator will have gravity applied.

Deleted the SB3 folder and re-downloaded, gravity plating still doesn’t work. SB3 is basically useless without it.

Why do I fall to the bottom of spacebuild maps? Back in SB2 I could float around.

I had the Same problem when i first started out, for a starter i would…

  1. Make sure You have all 3 addons, Rd3, Ls3, and Sb3
    2.Make sure their updated with the official Svn
    3.if that dosent work then you might want to try to reinstalling the already listed 3 addons, in my initial download they were messed up

Sorry i chouldnt help anymore all i know it thats what i did and it worked for me!i hope it works for you

-Me

As above but also with the addition that you make sure its all in the addons folder to begin with - it is not a game mode now, its a dummy.

Also note that many SB original SB maps wont work with it, you may have to find Sb3 versions.

Thanks LokiSan i forgot to mention that