Spacebuild 3 broken since 2/8/11 update.

Since I updated my server to today, SpaceBuild 3 is broken.

*On sb_gooniverse, there is gravity and air in space and all planets are habitable. Underwater, the air bar shows up at the bottom of the screen, indicating that Life Support is working.

*In the Custom Addon Framework menu, Spacebuild is disabled. Attempting to enable it fails with the message, “Couldn’t Enable the Addon for the for the following reason: Not on a Spacebuild Map!” Once again, I’m on sb_gooniverse.

Anyone?

Just got the gmod update on my servers, I’ve got spacebuild. Try to spawn a ship, keeps saying “This Stool is not Active”. Everything spawns fine but the life support crap. Maybe the update broke LS? (Wouldn’t be surprised). Using Adv. Dupe to spawn the ship.

Oh, tried spawning some Storage Devices with the Storage Device tool, again, this stool isn’t active. The resource nodes screens aren’t even there, its just a blank node.

Just tried to enable everything, got to Spacebuild and got same results as OP. On Astria_Beta01

I’ll check it out first thing in the morning. Seems like a hook or some map info isn’t available anymore.

Any quick fixes for now?

Sorry, but no. The checking if it’s a spacebuild map or not happens together with the loading of the logic_cases. If it can’t find any, or they aren’t planet, sun, … info. Then the code will detect it as not being a SB map. So even when disabling the “is sb map” check, it wouldn’t be able to find any planets, since nothing would have been loaded.

I’m not on a computer able to run garry’smod either atm, so I can’t test out anything.

If you are interested in looking at any of the code though, here are the places of interest:
(Based on the files on the development svn)

lua/CAF/Addons/server/spacebuild.lua

  • r360: local function Register_Environments() (function in charge of loading all the logic_cases)
  • r706: function SB.__AutoStart(), should get run on startup of the map and call the function above together with some others.

As a side note: do any of the other CAF addons have these issues or only Spacebuild?

[editline]9th February 2011[/editline]

And another question: Are there any lua errors in console when starting up a map?
If there are, they might be the cause of one of the functions not running correctly.

The other CAF addons seem to be fine, although they’re always disabled by default.

No, none from CAF or the like.

I enabled logging on the server console and seen this, not sure if its always been there or not, but it may help

Hook ‘CAF_Start’ Failed: [@lua\includes\extensions\string.lua:191] bad argument #1 to ‘sub’ (number expected, got string)

Thanks, this is one of the error’s I just read about in the “niggles” thread. Which seems to be a bug in the base code. Going to check where I call it. And see if I can’t do a quick workaround.

gives DevTeam a cookie

I have no idea if this will fix the problem, but I’ve commented out some calls which in terms call string.sub (error above).

The updated file can be found here:
http://gmodsnakesvx.googlecode.com/svn/trunk/dev/3.0/Spacebuild/lua/CAF/Addons/server/spacebuild.lua

It’s just a temporary fix (if it even fixes it) till I’m able to properly check/test in the morning.

Kk, TornadoChas3r will test 'er out on our servers.

Same Results

try rebooting your computer.

Still not working unfortunately, SB3 wont enable and the same error is displayed in console as well. Hopefully some others will test this out as well.

did you rebboot your computer?

Yes

Jokes aside, this is not a client side issue ;p

flipflop, the big ppl are talking, kay?

Rebooting won’t do squat. This is a Gmod issue.
Besides to add a new LUA file to a server, it has to be restarted anyways for it to take effect.
So in a sense, yes, he “did reboot” it to no avail.

How many times?

3 times “You always tell me to do it 3 times man”
(joke from a certain video if you did not get it)