Spacebuild Enhancement Project won't load

I’m trying to host a Spacebuild server on my linux box, but somehow, the SBEP addons won’t load.

The following addons are installed:
Advanced Duplicator
CAF
Dynamic Gibs
GCOMBAT08 (I also tried PewPew)
LS3Core
LS3Entities
RD3
SB3
SBEP_Entities
SBEP_Experimental
SBEP_Fortifications
SBEP_Models
SBEP_Weapons
wire
wiremod_extras
wiremod_models

When the server starts, it says the addon is loaded, “Loaded Spacebuild Enhancement Project”. It doesn’t say that when I join like the other addons do “Spacebuild addon enabled, etc”. When I try to spawn a prop, nothing happens, no errors, nothing.

The remove dupes command doesn’t work in the console, so I think the addon isn’t being loaded at all. I’m running Debian 6.0.2.

Any thoughts on this?

@The Mad Man
i guess try windows :s

That’s not an option, I assume there are other linux server running the addon?

“When I try to spawn a prop, nothing happens, no errors, nothing.”
Linux & gmod has problems with case sensitivity.

The Wiki’s recommendations for fixing this:

Thanks for your information!

Could you perhaps give me some pointers as to how to fix this? Also, should the names of the models themselves be changed or the pathnames in the lua files?

I don’t remember if I did both or just the models themselves, but I remember doing at least the models themselves.

Finally, I found the solution to the problem.

This is indeed because of casing, which can be solved with making all filenames and foldernames lowercase.

This can be done by using the tool ‘convmv’, which can be downloaded from the repository.

Under debian or any debian-like os like ubuntu, the command for installing convmv is as follows:


apt-get install convmv

Now navigate to the garrysmod/addons directory and execute the following command:


convmv -r --lower --notest SBEP*

This solution was found at http://www.snakesvx.net/forum/viewtopic.php?f=2&t=1110&view=print

Thanks for your help!

Psst, I added this to my FAQ with credit 'n such.