Spacebuild map and Occluder

I thought i had found a great way to reduce the lag on spacebuild maps drasticly. Since A lot of players will build ships and other space craft on planets with tons of models, i had this great idea to protect the open space from rendering these by using occluders. The results were quite satisfying, untill i have encountered a problem. It seems like that Occluder only works on a limited range.

Take a look at these screenshots.

This is a schematic of a random planet that is in my map:

http://img708.imageshack.us/img708/7766/schematic.jpg

The following picture contains a load of models, causing a very noticable FPS decrease. It is taken from within the atmosphere. The FPS is around 12ish:

http://img704.imageshack.us/img704/7169/insideatmo.jpg

This picture is taken from barely within the atmosphere, just outside the occluder brush (which is a sphere). The FPS is quite high here, around 60.

http://img16.imageshack.us/img16/4834/outsideatmo.jpg

Screenshot of “earth” with the “r_visocclusion 1” command enabled. You can clearly see that the Occluder brush is doing his job. The green lines indicate models that are hidden behind the occluder brush.

http://img515.imageshack.us/img515/3764/earthclose.jpg

Screenshot of “earth”, but at a greater distance. It seems like occluder stops working at a greater distance. That issnt really what i had in mind.

http://img251.imageshack.us/img251/4185/earthfar.jpg

So, is anyone having any idea of what is happening here? And is there a way I could possibly solve this?

Thanks in advance!