Spawning is glitched to hell

So, I would post in the Bug reports section, but no one seems to check those unless they have a thousand upvotes so I’ll post it here.

I was trying to get myself to my house by spawning in my sleeping bag, so I did kill in console and tried spawning it. It showed me sleeping in it, but then I couldn’t “Click to wake up” it just kept me there sleeping and the button wouldn’t work.
So I open console, type kill, and it “kills” me, but I’m still there in my sleeping bag. My escape menu doesn’t work, F2, chat, nothing works. I can’t respawn or anything. Frustrated, I update to Experimental Branch to try and see if that worked, but unfortunately I was killed and sleeping bag destroyed before I got that chance.

So, now I’m playing Rust again on the Washington server, and I feel like killing myself a few times to get out of the snow biome/desert biome.

On the third consecutive kill command, it showed me sleeping inside someones house. Not sure how I got there, if he just managed to build on a spawn point or something, but yea. Then, lo and behold, my spawn button doesnt work, yet again. I exit the game, restart it, and I ended up respawning somewhere else.

After about ten minutes of playing, I was just running in a line to get somewhere and BOOM I get teleported instantly to where that house was that I spawned in, Im in the floor, holding my rock out, looking at my old body that hasn’t respawned yet but isn’t killed. I can’t move, chat is broken, I need to click to wake up, but, it doesn’t work. I still have my rock, I’m still technically alive, but apparently I’m not. I try spawning and it says I can’t because I’m not dead. So I type kill in console, it “kills” me again in reality its doing nothing, and then I still can’t spawn afterwards. In console it says something along the lines of I cant wakeup because sleeping is 0. Here are a few screenshots. I’m not embedding them in the post because they are very big.

http://cloud-4.steampowered.com/ugc/547510480673125797/7D3B8F2BE1B7A7257BE790FC12AA8677680783A4/

http://cloud-4.steampowered.com/ugc/547510480673150356/8D8183415701BCFF6CA6836E49E2C347B226AEA8/

http://cloud-4.steampowered.com/ugc/547510480673151915/5A7434DF1E9B376D4FBFB46F1C9222EB8EACA3B2/

I am on the most recent build, the Experimental Branch. Idk why this is happening to me but it doesn’t seem to happen to anyone else.

http://support.facepunchstudios.com/feedback/view/300-the-wake-up-button-does-not-work-when-i-join-a-server

That doesn’t help at all. It just happened again, I was killed and it brought me back to my body that was in the house and I can’t leave the screen.

All I wanna fucking do is play Rust but this is literally ruining it. How can you fuck up respawning in a game? Honestly. Just get rid of the whole click to respawn thing its clearly ruining everything

Yeah, unfortunately experimental is much more glitchy than I thought it would be at this stage. Glitches will happen. I do however think it was far too early to make the exp the default option. They’re making great progress, but exp is in its infancy and has a significant amount of work to be done before I consider it playable. I love the direction, but it’s just too early.

admittedly i wouldnt object to losing the “wakeup” phase of respawning in exchange for doing it automatically.

The wakeup phase is ruining this. I am perfectly ok with handling the bugs and little stuff but there are a few game breaking bugs that just ruin the game. Like this respawning shit. And some guns not working and what not.

Is this issue covered by this?

I’m not sure, but I do know RustUpdates posted on Twitter that they tweaked the spawning a bit and it should fix the wake up bug, so maybe that’ll work.

If it makes you feel any better, I endured the exact same problem as you described two days ago. Hopefully they’ll fix it completely with the next update, because it does make the game difficult to play.