Spray Uploading problems

I’m trying to upload a spray (.vtf, 54kb, 128x128) but whenever I go into Gmod to upload and use it, the spray and any other file that could be uploaded all have a size of 4,096 MB. Every time I start Gmod up, this happens. Not a huge problem, but anyone have a fix?

New updates didn’t help; none of my friends know what the problem is; I even tried using a clean gmod. Now I’m hopelessly stuck D:

Try a targa file conversion, Google goes a long way y’know

What?

i think the problem is the .vtf (dont hold me to that)

Tried targa conversion, still can’t upload.
The vtf’s size is otherwise fine outside of gmod (54kb).
What I’m saying is, all my files are 4,096 MB and I can’t upload them.

Here’s a picture…
http://img638.imageshack.us/img638/917/helpko.jpg
Also noticed the date for every single file is the same, too.

File browser is broken, or your windows is. Does it happen in other games?

the problem is JPEG, Change the format

He already tried targa, which sprays are optimized for, by any chance are you gimp? anyway every one of my pictures on my PC are 4,096 MB as-well but it still works, does it say that it’s corrupt when accepting?

Ow dear, It appears I’ve been struck with the same bug, except I can import and upload sprays fine.

Only happens on Gmod, and good to know I’m not the only one with this problem. However, I can’t upload anything as it gives me no error messages. I KNOW the file is right size and everything, but it won’t upload.

One last bump to see if I can get this fixed?