Sprays not showing up on my Server

Hello everybody, I have a TTT Server with fastdl so I have sv_allowdownload and sv_allowupload both set to 0 and sprays aren’t showing up. They also didn’t show up when I set sc_allowupload to 1, I did notice they showed up only for the person who placed them when I ran the command cl_playerspraydisable 0, but as I said. Only for the person who placed them. Any suggestions? Here is most of my server.cfg:


//SERVER SETTINGS
sv_password ""
sv_lan 0
sv_alltalk 1
sv_cheats 0
sv_pausable 0
sv_filterban 1
sv_forcepreload 1
sv_alltalk 0
sv_footsteps 1
sv_voiceenable 1
sv_voicecodec vaudio_speex
sv_timeout 120
sv_deltaprint 0
sv_allowupload 0
sv_allowdownload 0
log on
sv_logfile 1
sv_logbans 1
sv_logecho 0
lua_log_sv 0
sv_airaccelerate 100
sv_gravity 600
sv_allow_wait_command 0
sv_allow_voice_from_file 1
sv_use_steam_voice 0
sv_turbophysics 0
sv_max_usercmd_future_ticks 12
gmod_physiterations 2
sv_client_min_interp_ratio 1
sv_client_max_interp_ratio 2
think_limit 20
sv_region 255
sv_noclipspeed 5
sv_noclipaccelerate 5
sv_kickerrornum 0

Thanks

sv_allowupload 0
sv_allowdownload 0

is causing that.

But wouldn’t changing them to 1 disable FastDL?

Just change upload then?

Didn’t work… as I said earlier.

Afaik no.

sv_allowdownload has nothing to do with sprays. Only sv_allowupload. The only issue is that if you don’t have RCON disabled, then anyone can get the RCON through allowupload.

Enabling sv_allowupload also did nothing.

Can all players not see sprays, or just you?