SQL not working on Openaura server

[MySQL]
force mysql_characters_table = characters;
force mysql_players_table = players;
force mysql_username = a3349032_resty;
force mysql_password = **********;
force mysql_database = a3349032_sovrpg;
force mysql_host = mysql10.000webhost.com;

The problem occurs after creating a character on the server, it will not continue after selecting character attributes. I also receive this error in my server console: Error connecting to DB: Can;t connect to MySQL server on ‘localhost’ (10061). I’ve googled for possible solutions for a long time now without success. I made sure to avoid the small mistakes such as not activating scriptenforcer or importing the SQL tables, so at this point I don’t have much of a clue. Any help would be much appreciated.

bump

That webhost doesn’t allow remote connections for MySQL.

/facedesk

Would you happen to know of any other SQL hosts that do allow remote connections?

Not a stable host but they allow remote connections.
(I suggest signing up with the Stevie server)

Thank you RJ and Chessnut, I got things working out now.

Sorry for the bump, but once again I find myself stumped. It seems the “Error connecting to DB: Can’t connect to MySQL server on ‘localhost’ (10061)” error has come back to haunt me. I am currently using a friend’s SQL server with remote access enabled, which he was able to connect to when he ran his server (using the same schema as me). I have come to the conclusion that this is no longer an issue with the SQL I use, but what the real issue is is still a mystery to me.

Help would once again be appreciated.

which host do you use? I bet its 127.0.0.1 ?

I am using a friend’s MySQL host and database (remote access enabled), but the real problem is that the error I am receiving in the srcds console relates to ‘localhost’ which is not what I am using.

[MySQL]
force mysql_characters_table = characters;
force mysql_players_table = players;
force mysql_username = root;
force mysql_password = **********;
force mysql_database = openaura;
force mysql_host = 83.233.77.89;

As you can see there is no localhost information in this mysql.cfg file, so I really have no idea what the problem could be.

A few things;

  1. Your IP changed: www.whatismyip.com
  2. The host name is wrong
  3. The host crashed

My friend has just recently tried starting up his server using the same schema and MySQL information and had no issues, I’m using the same SQL as him as he has given me remote access. I think we can rule out incorrect MySQL information as the issue. If worst comes to worst I’ll re-install my srcds and re-download the files, but I want to make sure that there are no other options first.

Perhaps you are familiar with the error: “Error connecting to DB: Can’t connect to MySQL server on ‘localhost’ (10061)”? I am certain that this is the root of all my problems, but the thing is I’m not running an SQL server on localhost, but connecting to a remote SQL server as I mentioned before.

Localhost is the IP of the computer you’re on and a remote connection of a SQL is connecting using your localhost IP (the computer you’re on). Not much else I can help with as I don’t know what else to do, sorry.

Ah well I thank you for trying, looks like I’ll have to reinstall srcds and hope for the best then.