SRCDS.exe acting weird

I’m just going to post this from the Steam forums so I don’t waste my time typing what’s already been typed.
[HR][/HR]
Hi,
I just updated Garry’s Mod 13 (dedicated server, “garrysmodbeta”) and I accidentally closed the window while it was verifying files. I use this batch file command to update:



hldsupdatetool.exe -command update -game garrysmodbeta -verify_all -retry -dir "c:\srcds" -username ******** -password *******

Recently, I try to start orangebox/srcds.exe, but all it did was either:

• run and then suddenly close, or
• show suddenly an error about no shutdown function for various things and close.

When I run the update again, it re-downloads the OB binaries and alternates between errors. If it was problem A, now it’s doing problem B, and vice versa. How do I resolve this annoying error that’s impeding me from running my server!

Additionally, the root srcds.exe (not in the orangebox/ folder) is saying “The specified module could not be found.”

Can anyone please help with this problem? Any help would be appreciated. Thank you! :v:

First of all… post anything GM13 related in the GM13 section… If you did… you would have seen by now that it is broken.

This is a general question since it actually broke srcds, not GMod 13. And because it is related to help on starting GMod servers, it belongs here. Last, GMod 13 isn’t broken.

I thought gmod13 was broken atm, and yes it IS a gmod13 related issue…

Nah. Garry fixed it Monday.

ah, fair enough :slight_smile: