SRCDS.exe closes as soon as the server starts

This is the message I get (retrieved through prtscn):


"Missing shutdown function for COM_InitFilesystem( info.m_pInitialMod ) : COM_ShutdownFileSystem()"

This is the text of the .bat I’m running:


@echo off
cd C:\gmodserver
echo Starting game server.
echo Starting Unaffiliated Gaming
srcds.exe -console -game garrysmod +map cs_militia +maxplayers 24 -tickrate 66 +hostname "~Unaffiliated Gaming~ | 24/7 Trouble in Terrorist Town"
echo Server has now started.

The initial command line seems to work fine but once SRCDS opens it immediately shuts down both command line windows. I have installed Counter Strike Source and Garry’s Mod. The server was working fine before I had installed CSS. I’ve tried using app_update validate for both GMod and CSS but to no avail.

Try updating SteamCMD itself, that seems to be a problem with SteamCMD, not GMod.

Isn’t SteamCMD supposed to automatically update? Nothing happens if I start it.

Not always.

Could just be a mucked install, do a fresh install and see if it works.

It’s worked so far, but I have yet to try using CSS content on it.

[editline]9th June 2013[/editline]

I installed the CSS content in a different directory, and entered the path to the cstrike folder in the mount.cfg in my garrysmod cfg folder. However it won’t let me use a CSS map.