SRCDS + GMOD clientport problems with In-game browser.

Hey guys,

I am attempting to host 2 srcds gmod servers from my Dedicated Server. I have successfully set up one and It is working wonderfully. But I want to setup another server and I am having a strange issue. When I attempt to find the second server in the server browser it shows up with the first servers information and connecting gets the first servers addons. I have already changed the clientport among other ports And am using a separate ip. I believe that gmod clients only search on 27005 for the default client ports? Or maybe its a issue with steam/vac stuff. Here are the two invocations that I am using to start the servers:

For the main server with the ports: hostport = 27015, clientport = 27005


-norestart -ip 69.197.136.30 +hostport 27015 +clientport 27005 +tv_port 27020 +host_workshop_collection [omitted] -authkey [omitted] -game garrysmod -tickrate 33 +gamemode prop_hunt +maxplayers 60 +map ph_office

And the new server I want to host: hostport = 27016, clientport = 27006


-norestart -ip 69.197.136.29 +hostport 27016 +clientport 27006 +tv_port 27021 +host_workshop_collection [omitted] -authkey [omitted] -game garrysmod -tickrate 33 +gamemode terrortown +maxplayers 32 +map ttt_skycraftfinal

If anyone could please shed light on this behavior It would be greatly appreciated. Thanks for your time!

Additional details:



--Centos version
CentOS release 6.5 (Final)

-- uname -a
Linux [hostname omitted] 2.6.32-431.17.1.el6.x86_64 #1 SMP Wed May 7 23:32:49 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux


If you need more details let me know.

It’s just -port 27015

Remove all the other port parameters

No Check again I am hosting multiple servers. And Want to use different ports. Also the -port flag for srcds provides the same result

Edit
But to humor you server invocations are now:


-norestart -ip 69.197.136.30 -port 27015 +hostport 27015 +clientport 27005 +tv_port 27020 +host_workshop_collection [omitted] -authkey [omitted] -game garrysmod -tickrate 33 +gamemode prop_hunt +maxplayers 60 +map ph_office

And


-norestart -ip 69.197.136.29 -port 27016 +hostport 27016 +clientport 27006 +tv_port 27020 +host_workshop_collection [omitted] -authkey [omitted]-game garrysmod -tickrate 33 +gamemode terrortown +maxplayers 32 +map ttt_skycraftfinal

I am hosting multiple servers on linux with only the -port command, so why shouldn’t it work for you?

-port 27015
-port 27020
etc

[editline]26th June 2014[/editline]

Here’s my startups:

./srcds_run -console -game garrysmod +map zs_last_mansion_v3 +maxplayers 24 -port 27045 +gamemode murder
./srcds_run -console -game garrysmod +map zs_last_mansion_v3 +maxplayers 24 -port 27055 +gamemode murder

Works for me, should for you.

Possibly The way my firewall works. I am only allowing traffic on those ips and those ports. I will try Your method and repost in a few mins.

[editline]26th June 2014[/editline]

Quick question are those the only gmod servers you host on that machine?

Looks to me like you’re using the same server files for both servers. Make sure you have two SRCDS installations and that your startup scripts doesn’t use the same paths to srcds_run.

At the moment, yes. Hosted 2 others but removed them yesterday.

Haha Wow I have never felt so dumb in my life. I was setting it up very quick last night and forgot to change my path. Thank you very much.

Sorry about wasting your time. I feel like such a idiot right now :stuck_out_tongue: