SRCDS not showing on list

Ok, I’m reposting my thread because no-one is responding to my old one, vBulletin can’t change thread titles so… I assume it was to do with the title so that’s why I’ve done this…

Anyway, I start SRCDS on my VPS, telnet receives a response! I can’t see it on the list if I add it to favorites, and if I use “connect <ip>:<port>” in the garry’s mod console to connect it doesn’t connect.

I’ve tried installing steam on the VPS to see if it’d show in LAN. The answer is no.

The server has sv_lan 0, and heartbeat. It loads garry’s mod and the addons.

Something else I might add: When it has finished loading it gets a “problem connecting to steam servers” message, but then eventually says " VAC secure mode activated" with the spaces.

Seriously though, this VPS costs £40 per month (high-end ;P) and I really need some help, I have no idea what to do.

I’ve contacted support for my VPS about this issue and they say no port is blocked, besides when the server is running I can use telnet to be sure of that anyway!

So can anyone help?

Thanks,
NonExistent.

OK, i reccomend that you home host them. First, if theres a error in there servers. Your paying, and your not getting what you want. So you wasteing your money…heres the instructrions to how to download it and open ports:

ok first goto here:

Now where it says “From The Valve Servers” thats in blue. Click onit, when a download box apears. Press Open. When its done follow the instructions and INSTALL IT TO “c:\srcds”. First make sure you have atleast 7.8 gbs of space.

Now go to startmenu\run and type cmd. When the CMD box comes up type “cd \srcds”. After that comes up. Type

“hldsupdatetool -command update -game “Counter-Strike Source” -dir C:\srcds”.

(Or somthing else in the place as CSS. You would put garrysmod,tf,ect.)

Now go out for lunch or somthing because it will take awhile!

When its done close it. Right Click on desktop new
ew text document. Open it and put:

c:\srcds\srcds.exe -console -game cstrike +map de_dust -maxplayers 16 -autoupdate

The Cstrike u would put garrysmod, or TF, depends on what game you downloaded. Then de_dust, put your server map. If u have Gmod u would put gm_flatgrass, or gm_construct. TF, u would put a map name aswell. Maxplayers is howmany players u want to alow on your server. If u have a system Below 1 ghz. Put somthing below 5. If its in the orangebox folder put c:\srcds\orangebox\srcds.exe -console -game garrysmod +map gm_flatgrass -maxplayers 16 -autoupdate

Then save it as “Srcds.bat” to desktop.

Now, make a new text document. And put commands init. Like if u have Gmod downloaded. You put:

sbox_noclip 1
sbox_maxvehicles 2
sbox_maxthrusters 8
sbox_maxwheels 9
sbox_maxragdolls 3
sbox_maxlights 4
sbox_maxlamps 4

sv_lan 0

hostname “Your Servers Name”

Now go to save as and save it as “server.cfg” with the quotes. Then save it to:

C:\Srcds\OrangeBox\garrysmod\garrysmod\cfg

NOW FOR THIS TO WORK U NEED OPEN PORTS!

OPEN PORT
27015 - 27020
27005

If u dont no how to open ports go to http://PortFoward.com

Look for your router, click on it, and the next page look for Half Life 2 steam server. Follow the instructions. REMEMBER 27005, 27015 - 27020 TCP AND UDP

Then Open up your Batchfile. Then YAY your done. If u cant fiqure this out, I dont no.

NOTE: FINDING A SERVER PREDOWNLOADED USALLY CONTAINS VIRUSES! DONT BOTHER WITH THOSE UNLESS U SCAN THEM FIRST!!

Edited:

Listen Server Ports(Ingame Only, Not Ded):

ports:

1200 TCP UDP
27005 TCP UDP
27015 - 27039 TCP UDP
27020 TCP AND UDP

I’ve done all that on my VPS. But screw homehosting. Seriously, I don’t want my machine on all the time due to my main being a laptop and my others lacking hard drives after I needed some money (^_^). Also, it’d be laggy as shit due to my internet being slow, I normally get a ping of like 100-200 in UK servers, so imagine if I had a server of my own running?! Try 1000-2000.

Anyway, I do actually need it on the VPS.

I have no ideas about what’s happening.

EDIT:
Ugh I made it show up on the LAN list and the server list, however, only on the VPS itself. I can’t make it show anywhere else. Just on the VPS :frowning:

Thanks though,
NonExistent

Might your VPS have an private IP address. I know when I had a VPS with KickAssVPS, they use private address internally for the network so you must use +ip 10.1.1.15 (or similar).

I got the problem sorted. Turns out they were blocking all UDP ports on 64bit systems except for 59 due to UDP floods, so now it’s 32bit and working. Thanks for trying to help though xD

Good to hear, just wondering, who’s your VPS provider?

VPSLand (they really SUCK support wise - support ticket replies take about a day).
I don’t really see what the server architecture has to do with ports? Oh well. It still worked.