srcds_run missing from Steampipe server

I’m trying to mess around with the beta gmod server, but I’ve run into a snag. There doesn’t seem to be a srcds_run script anywhere that I can find. srcds_linux is there, but that’s it. The other steampipe servers I installed (cs:go, tf2) each had srcds_run in the expected location. I just can’t figure out how to start this thing.

Am I missing something obvious?

Oops - thanks, just added it

Thanks, Garry!

When should it be available for steamcmd to fetch?

Do I have to do anything on my end to get srcds_run?

Has it still not showed up?

It took a few hours, but yes, it has shown up now. Thanks!

I have another problem now, though. I get this in the console when trying to start the server.


Auto detecting CPU
Using default binary: ./srcds_linux
Enabling debug mode
Server will auto-restart if there is a crash.
WARNING: Failed to locate steam binary.
WARNING: Could not locate steam binary:, ignoring.
System (VMaterialSystem080) failed during stage CONNECTION
System (VMaterialSystem080) failed during stage CONNECTION
cat: hlds.1244.pid: No such file or directory
email debug.log to linux@valvesoftware.com
Sat Jun  1 08:50:44 CDT 2013: Server restart in 10 seconds

An old thread here suggests there are some missing files in the bin folder. The binaries mentioned in the post are missing, but I don’t know if this new version is even supposed to have them. The debug.log shows nothing except for the start command. In case it’s relevant, here it is.


./srcds_run -game garrysmod -debug -console -usercon -autoupdate -steam_dir /home/gmod +hostport 27015 +ip 0.0.0.0 +net_public_adr 0.0.0.0 +map gm_construct

I’ve tried a few variations with no luck. Even just “./srcds_run -game garrysmod” results in the same message.

I am having this exact issue. I would love to know if there is any solution.

I have also tried numerous kinds of troubleshooting.

Steampipe has been fucking people over ever since it came out.

Useless Valve updates; I’m not the least bit surprised.

Except its not useless. Just search the benefits and they outweigh all the benefits. Steampipe is still in its infant stages anyways; half of the games are only on a beta. Just give it time and it will be resolved.

As to help your issue, Garry said he pushed an update to fix it. Try now.